Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mx920 Wireless printing problem


I have just bought an mx920, beautiful printer I may point out, it worked well for the first two days but I cannot print as of today, I connect to the printer wirelessly and all my computers are Macs.

The printer is connected to the network properly and my computer shows that it has an active connectiong, but when I click print the printer goes to "in use" and then goes offline, and the Print Que says "Printer not connected" 

I've tried connecting the printer to the network again, and I have restarted the printer along with my computers but it still wont work. 

Please help 

159 REPLIES 159


Im having the same problem printer works fine then the next day i get the same message...the only solution i have found for now is power on/off the printer and it goes back online and prints the documents.


Is their a fix for this?

Idiot printer keeps dropping the access point and can't find it again.  The only fix I can figure out is buy a different printer.  And definitely not Canon. Ever again.

Hi dagaz10000!


Welcome to the Canon Forum, and thanks for your inquiry! We're sorry you're having a problem with your PIXMA MX920, and we'd like to help! So that the Community can help you better, we will need to know any error messages you're seeing, and the Computer Operating System you're using (Windows XP/Vista/7/8 or Mac 10.x).

Any other details you'd like to give will only help the Community better understand your issue!

If this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team by phone or email.

Thanks and have a great day!

I have the same issue, it is irritating more than anything else, but the mx920 is configured wireless, and prints just fine. But if left on for a length of time (ie. don't print until the next day) then when I do print, the printer is now offline and the only *fix* is to power off , then power on.


I have look at my wireless settings, if there is something I need configured, I'm not sure what it is, especially since my other devices are fine.


I think the power off/on forces the printer to re-establish communication with the Linksys (my wireless router) EA3500,

and when I look at the status, the printer is online after the power on, but eventually will show the printer offline. For which I once again need to power cycle to get the printer working.







I have the same exact issue as described by Jim. Has Canon provided a solution/fix for this? If not, I'll just return the printer via Amazon, it's just not worth my time and the hassle.





Hi Canon you can also add me to the list of MX920 wireless printing problems.


Like listed above it worked fine at first and now everytime I need to print something I need to restart the printer in order for our laptop to find it.


MacBook Pro OS X 10.9  and MacBook OS X 10.6.8 have the same problems.


Thank you for your help and hopefully we can get this fixed.

You know Canon, I raved about how well your old printer worked.  I buy a new printer and I cannot get my documents to print!  So, I called the 800 tech support number just to be told it is NOT THE PRINTER!  Yet two differnt lap tops cannot connect!  I CHANGE NOTHING ON MY LAPTOPS, I DON'T RESET THE NETWORK AND ALL I HAVE TO DO IS REBOOT THE PRINTER AND IT WORKS FINE AND YET I AM STILL TOLD IT IS AN APPLE ISSUE OR ROUTER ISSUE! Realy?  This is the EXACT reason why I STOPPED using HP printers! 



Called Apple and as I suspected they said since I did not have to reboot the laptops or router in order to get documents to print it most likely is a printer issue.


Called Canon back with my fingers crossed that I did not get the same Tech Support person, thankfully I did not.  Told him my issues and what a surprise he did not start telling me how it wasn't a Canon issue, he actually asked my name, asked for the serial number and made the effort to help!  After a couple of checks of the printer we determined there was a firmware update available.  The old firmware version was 1.0.X and the new one is 2.0.0 and it appears the printer is working properly.  I was provided a case number and if the problem returns this issue has been documented.  Hopefully Canon actually does listen to the tapes and will pull the first Tech Support because he was not a good Canon representative.

Firmware update was one of the first things I went after, also the driver, but according to the canon website, there  is no firmware upgrade for the OS that I'm on, which is Windows 7. I'm not sure what OS I print from has to do with anything, as I also print from my Mac. The printer is not connected direct, only wireless.


Also, I looked to see if I could find out what version of firmware I am on, but nothing is documented, and I cannot find out what version the printer is installed with.


Any hints on how to find that information, I would be glad to provide it.