Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mx920 Wireless printing problem


I have just bought an mx920, beautiful printer I may point out, it worked well for the first two days but I cannot print as of today, I connect to the printer wirelessly and all my computers are Macs.

The printer is connected to the network properly and my computer shows that it has an active connectiong, but when I click print the printer goes to "in use" and then goes offline, and the Print Que says "Printer not connected" 

I've tried connecting the printer to the network again, and I have restarted the printer along with my computers but it still wont work. 

Please help 

159 REPLIES 159

There are numerous threads on this same issue.  In another thread with link below, I hope to have fully explained why recycling the power to printer does not always work in trying to re-synchronize printer and router after connection has been dropped due to sleep mode or printer power off, and, the DHCP dynamic addressing has now assigned the originally assigned printer IP address to another device.  I hope this helps.


None of these solutions have worked for me.  IMac w Yosemite OS.  Local Area Network.  Computer connected to printer through USB and both connected to TIme Capsule as the airport stations. 


I have powered down, downloaded latest updates and there is no firmware available on canon site...VERY FRUSTRATING - it essentially stopped working for me 4 months ago after working well.

@MMGates, how about clearly describing your problem, and which of the many troubleshooting ideas posted previously in this forum thread you've tried? Also, it's unclear what you meant by "connected through USB" since this forum thread is about the printer losing its wireless connection... perhaps it would help if you express yourself using complete sentences.


I phoned Canon customer support and they walked me through fixing my problem.  We use wireless LAN at the house.



I have a mac, my wife an iPad.  We would be able to print a document, then after aprx 10 minutes I'd have to enter our router password again.  Our home office was not so printer friendly.  Our printer was located in an adjacent room aprx 25ft away.


Solution to OUR Problem:

Well, I finally phoned Canon Customer service and she ran me through a function test that printed out a report to check the signal strength from our router to the printer.  Well, our signal strength was at 84%.  


Here is the process they walked me through in order to see my signal strength and confirm my settings.


Click "Menu" , then click "Set Up" (the tool icon), then click "Device Settings", then click "LAN Settings", then click "Confirm LAN settings", then click "Print LAN settings"...then click "Yes" to Print Network Configuration Page


On that page verify:

1. that you have a IPv6 IP Address & Default Gateway (dont ask me how or what that all means...she just advised me that I should make sure that there is one in there...if there was not one in there then there was something wrong with my router or my actual connection/password)..


2. Signal Strength

She advised that it should be as close to 100% as possible..  Again, ours was at 84% and she said, "yup, thats your problem"..


Solution Day 5

The printer has been working flawlessly.  I can print something out in the morning, go to the gym, come back an couple of hours later and I can print again...Before, I would have to re enter our router LAN password.


Hope this help some of you out...  



Disabling the IPv6 on the printer resolved my wireless connectivity issues completely.

Can you give me the canon customer service number you called? I have found more than one

1-800-652-2666 Central Time at 10:50 ish....  Customer service answered quickly..
New Contributor
Posts: 4
Registered: ‎05-26-2014
Re: Mx920 Wireless printing problem [ New ]
Can you give me the canon customer service number you called? I have found more than one


Solution here: Updated Router Firmware to solve the problem in my case.


MX922 printer (firmware v2.01) started to become disconnected over the wifi network over the past week.

About this same time I noticed the amber LED flashing on my router (Airport Extreme) which indicated there was a firmware update pending by the manufacturer. (These updates come somewhat frequently so I do not respond to them immediately and usually do not see any side affects).   


However, after troubleshooting this printer problem for several days, I decided to update the router firmware. Afterwards, all the computers began detecting the MX922 printer properly. Thought I would share this in case it helps anyone else.



Heppened again to me the other day. Printer not available to computers over wireless network. This time, thr router appeared fine (green LED indicated normal), but I restarted it anyway. That solved it, until next time! 


Success after restarted (power off/on) wireless router.

I don't know if you read all of the posts on this topic, but this is the solution that worked for me (excerpt from message #90):


"The solution that worked for me so far was to go through the printer setup process again, select the access point, and enter the password."


I hope it works for you as well.

click here to view the gallery