cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mx920 Wireless printing problem

slashmon1
Apprentice

I have just bought an mx920, beautiful printer I may point out, it worked well for the first two days but I cannot print as of today, I connect to the printer wirelessly and all my computers are Macs.

The printer is connected to the network properly and my computer shows that it has an active connectiong, but when I click print the printer goes to "in use" and then goes offline, and the Print Que says "Printer not connected" 

I've tried connecting the printer to the network again, and I have restarted the printer along with my computers but it still wont work. 

Please help 

159 REPLIES 159

Yes - thanks, but I have totally uninstalled and reinstalled twice - going through the whole Canon menu set-up sequence each time.  I can figure out a way to manually scan an image to my desktop, then drag it into an email.  But I used to be able to get an image directly scanned into an email...in other words, an email would pop up on my PC screen, ready to be filled in with subject and  recipient's name. Now when I punch the scan button on the printer screen, the only option is "Attach to E-mail Local (USB).  There should be a way I can select that message then scroll to another option to use Wifi instead of Local USB. I cannot, however, get to that particular message by punching the up arrow. Just get the little bell-type signal that that action is not valid.

WAIslandMan
Apprentice

I suffered from the same problem sometimes where the printer could no longer be recognized on the wireless network after the printer entered standby mode and then woke up (the printer head would shake and move on wake up, but then fail to print).

 

The solution that worked for me so far was to go through the printer setup process again, select the access point, and enter the password.

 

Success!

thank you for helping.

MMGates
Contributor
I called the customer support. The basic solution for me was to shut off printer, then unplug router (Time Machine) then wait 30 seconds plug it back in and then turn on printer and renter access pint password. I have Mac that runs Yosemite. Although a pain it seems that when router updates or power outage things need to be restarted. Solves problems.

vanlandingham
Apprentice

I found this on some Canon support site where they responded to a customer. It worked for me!! I have been doing the reinstall, reboot, readd wifi bs forever:

 

a) Press “Windows Logo” + “R” keys on the keyboard to open the “Run” command box.
b)Type “Services.msc” in the “Run” command box.
c)In the “Services” window, double-click on “Print Spooler” service to open the properties window.
d)Stop the service, if it is already running and then restart the service by clicking on the “Start” button.
e)Now, select “Automatic” from the “Startup type” drop menu.
f) Click on "Apply” and then “Ok”.
g)Close the “Services” window and restart the computer.
h)After the restart, check if the issue persists.

elmatic0ne
Contributor

so I have come to the conclusion that it is how the printer and the router connect with each other and in the end, as ridiculous as it may be, the fault can be placed on the router for not playing nice with the printer...or the printer with not having the ability to offer a universal communication between routers regardless of manufacture

 

I had wifi connection (or lack there of) issues when I had internet with rogers and their modem/router. I then switched to Bell and used their modem/router. No issues what so ever. It was a great 6 months printing wise. Static IP assigned, able to print from multiple systems and devices - ipad, iphone, macair, windows pc.

 

Just switched back to rogers with their modem/router - wifi connection issues again. My only option is to set the modem/router to bridge mode then add an additional router. Really irritates me that I have to introduce an extra piece of hardware when this really should not be a problem.

chuckm
Apprentice

There are a lot of things in this thread that I would like to try.  If I could print them without carrying my laptop into another room and connecting it with a USB cable, it would be great.

chuckm
Apprentice

BTW, the current firmware for this seems to be 3.0 and can be downloaded from the printer as some of the above instructions demonstrate.  However my printer still does not work wirelessly.  

chuckm
Apprentice

For the moment, I can see the printer from my MacBook, My wife's MacBook, and my iPhone and iPad.  I don't know when the 3.0 firmware was released, but I sure hope I can come back next week (or even tomorrow) and say that this is still working.

Hello, chuckm.

 

Additional troubleshooting will have to be done to narrow down the cause of your issues. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Avatar
click here to view the gallery
Announcements