cancel
Showing results for 
Search instead for 
Did you mean: 

Mx920 Wireless printing problem

slashmon1
Apprentice

I have just bought an mx920, beautiful printer I may point out, it worked well for the first two days but I cannot print as of today, I connect to the printer wirelessly and all my computers are Macs.

The printer is connected to the network properly and my computer shows that it has an active connectiong, but when I click print the printer goes to "in use" and then goes offline, and the Print Que says "Printer not connected" 

I've tried connecting the printer to the network again, and I have restarted the printer along with my computers but it still wont work. 

Please help 

159 REPLIES 159

Same problem. 

 

Instant error when printing. 

 

Lan DRX disabled. IPv6 Disabled.

 

pic

NoWake200 - thanks for the info.  I'll try to make a report BEFORE I reboot the printer next time.  Is there someone we can email the reports to or should we just post results here?

 

It's now July and a few months since you posted how to print out the LAN settings in April, so hoping a fix has been found or at least being worked on for the next firmware update or driver?

 

Windows 7

MX 922

firmware: 2.020

 

If I'm reading it right, my driver is from 9/20/2012 vers. 2.65.2.10

 

I'll post a LAN report the next time it falls off the network.   I haven't disabled Ipv6 or LAN DRX, since neither of those seem to fix it anyways.  

 

TIA

It is my understanding that there is not yet a fix.  The problems we are having are with no rhyme or reason.  Just a few weeks ago I called in again when the printer just stopped working.

Hopefully someone will come out with a fix sooner than later, because each customer that deals with this particular printer may very well have purchased their last Canon printer or product.  But I am sure they are aware of that.

Thank you for the reply.   

 

And you're right, this is my first non-HP printer in over 15yrs.  My previous HP died at a bad time, and I needed a replacement quick.  This was on sale, so I took a chance.   AND..   Since I work from home, people are always asking me what models I use or what brands are good.  Right now I can't say I'd recommend Cannon for wireless. 

 

 

My wireless has a limited number of connections, so I could see the printer potentially getting knocked off, but it should be able to find the network again without a reboot, or me manually resetting the wireless. My HP printer doesn't have to be rebooted/reset.  (It's an HP)  *shrug*

 

It seems like it should be able to be fixed with a firmware update.  Maybe stop the sleep mode or add a wake-up activate mode.  I just hope we don't have to swap out a part, but if it's not much worse that changing a printer cartridge I'd be willing to try it.  

Same problems here. Did everything we know to do, and even worked with a IT network friend for 4 hours yesterday. Nada.

 

We've rebooted everying, and looked for new software.

The printer claims to be on the network.

We've used the fixed IP address solution - which worked until a couple days ago.

The Mac is certainly on the WIFI - I'm using it now.

Routing has very strong signal.

When i ping the printer from the Mac it finds it just fine.

Print jobs just won't go through.

 

This is among the most frustrating things I've ever dealt with.

The irony is, Consumer Reports just gave our printer high marks and made it their choice pick in this month's addition! 

 

Robot Embarassed

Is there any solution?  I am using the Mac OS X 10.9.5 - error messages are either no airporinter can be found or "THe Printer is off line"

 

I have tried power cycle....nothing is working anymore.

 

Help

MMGates, when you say you tried "power cycle" do you mean you turned the printer off and on, or turned the computer off and on, or turned the router off and on?  I think I read that according to Canon you need to pause for about 30 seconds after you turn off the printer, before you turn it back on, to make sure it has enough time to go completely off.  If that doesn't work, maybe you should try turning all three devices off and on, if you haven't tried that.

 

Also, did you test the solution that seems to have worked for me, which I described in the message I posted here yesterday?  Can your computer's web browser access the printer's built-in web server?  If so, and if the printer's web server shows that the printer's Location property is blank, enter a value into the printer's Location property (and then save the new settings).  Let us know if this works for you.

 

You might have a different problem than the rest of us.  Our printers work for awhile when we turn them on, then later after hours of inactivity they stop working (behaving as if they go offline).  You say yours doesn't work at all, if I understand you correctly.  If your computer's web browser can't access the printer's web server, I think you should try troubleshooting the wireless connectivity.  Use the printer's built-in menu to display its settings and make sure it's still properly set up, and select the option that prints the settings (for reference later).  Access your router's web server with your computer's web browser to see whether the router shows the printer is connected.  Also, consider temporarily moving the printer close to the router if it's far away, and consider temporarily installing it as a USB printer to test whether the problem is something other than the wireless connection.

 

Also, consider contacting Canon's toll-free tech support for assistance.

 

Good luck.

Another_Victim Good morning from GREECE ON pass these these settings said . How many days is the printer you on line.

I'm not sure I understand Dimitrisprev's question, but here's some more information: About a week ago I used the printer's web server to enter a value into the Location property. Since then it hasn't had any problem. The longest test (the longest period of inactivity) since the change has been about 3 days. Before the change, it would stop working after hours of inactivity.

Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM