Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

... and yet according to Canon it is not a know defect.

incredible! The old CYA

Looks like there is no where one can get the spare part #7226 020. I am heading for Japan in a few more weeks and see if I have any luck there. However, I just found a guy who made a hack repair on his S100 shutter switch. If I come to a dead end, I may try that too. His simply soldered the "double layer switch: one for focusing and one for taking picture" together to make it work. So it will focus and take the picture at the same time. Here is his link. I am not sure if this has been posting in this site before or not. [Mod Note: Link removed per Forum Guidelines]


See this is another reason why I bought a used working S100 which still works, there is plenty of repair info out there!

One thing came to mind after reading his "fix" which I would consider instead of having  it focus and shoot at the same time. Instead of jumpering out the exposure side of that switch in paralell with the focus side why not run the wires out of a small hole drilled thru the top cover then attach them to a small button type switch which could be fixed to the top with glue or even velcro. Then you'd still have the same control over focus with just a seperate switch for exposure nearby?

Just a thought


Ha, ha, may be you can even use a voice activated switch so that you don't have to use two fingers:-) I didn't know you cannot put web link here but this guy is called Martin Jones and his article is called Canon S100 Shutter Button Fix. See you can look it up. (

... or attach a tiny heating pad with its own switch. Just press the heating switch, wait a few seconds and take your picture as usual.

when you get the camera apart you will see what a challenge any soldering would be. I was an electronics technician many many years ago -- but these parts are so tiny and delicate -- you would need very specialized, highly temperature-controlled soldering iron.

I'm sorry to report that it was a coincidence.  Blink detection has no affect.  My shutter will sometimes not work either way.  It's amazing to me that the camera will work fine for 3 days and then stop working.  Man Sad

Don't worry, it will stop working altogether eventually. Have you tried the warming method? Shoot some video and then take a still.


Hello fellow shutter sufferers,

I am also experiencing this problem. It's been quite a hassle.

My warranty is nolonger valid, though I purchased it less than 11 months ago, as the serial number has worn off since. I'm sort of at a loss.

Has anyone sent it off to be repaired, or gotten any definitive answer about what the problem with the shutter release is?

Any feedback would be greatly appreciated. This forum is the only record of the issue I've found online.


click here to view the press release