Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Yeah Canon won't care once your warrantee is over.

In my case, I sent my camera in 3 (THREE) times while it was under warrantee to fix the shutter issue.  The first time I sent it in they replaced the lens assembly.  It didn't fix it.  The second time I sent it in they returned it to me untouched, saying they could not duplicate the issue.  Argh.  I immediately sent it straight back and this time around they replaced the top frame assembly. But the issue still wasn't fixed.  Now my camera is out of warrantee and my camera is useless due to the shutter button only focusing but not actually taking pictures.

Thats awful ! If you still have all the documentation from sending it in you have a good case to present to the BBB in addition to the numerous other complaints in this thread.

Unfortunately I don't have the documentation papers of me sending it in.  However I did talk to customer service at Canon after my second return, and I remember they were able to see that I sent in my camera based on the serial number of my camera.


I don't think I'll be able to get help from the BBB because I don't have the documentation of warrantee work on hand (I doubt Canon will be forthcoming in sharing that).  Plus the warrantee on the camera expired for me around May 2014.  I was too peeved at the time and gave up on the camera and didn't think to utilize the BBB.


Different day, different person, same problem... Shutter release not working on my S100 camera. By the number of people complaining about the same problem, it's not just a occasional misshappen! Very disapointed with Canon, time to go for GOPro. Bye, bye Canon...

The fix described above by others worked perfectly for me. Buy some DeoxIT D5. Remove camera battery and sd card. Remove the front case of the camera using a Phillips head size-00 screwdriver, being super careful not to dislodge the electronic ribbon that runs from the camera body to the bottom of the case (and don't drop the paper-thin black washer-type ring that sits on front of the lens assembly. I didn't bother removing the back case or top assembly. Squirt DeoxIT into the gap under the shutter button, using the directional straw attachment that should come with the DeoxIT. Wait 10 minutes, reassemble and voila: My s100 is behaving as new. It's a five minute job. If not confident pulling things apart, take your camera to a mobile phone repairer or similar; it shouldn't cost more than a few bucks.



Thanks. Your fix worked for me also.

Try the Deoxit fix posted here. Easy, Almost fun. Worked for me.




Just bought one of these S100s from ebay. I had previously owned the S90 and was impressed with it, so I updated.


Anyway, mine had the shutter problem as soon as I received it and I concluded it may be a contact problem. I have a product specifically for cleaning electrical/electronic  contacts in a pressure pak can. I held the camera upside down and gave a spray with a nozzle around the circumference of the shutter button and it worked immediately. It worked first time every time after that, until the next morning when I had to repeat the procedure, with the same result.


This particular spray dries instantly and there is no danger of causing a short circuit or interacting with other components, it also doesn't affect the plastic body parts. (although the instructions recomend testing first).



The zoom switch/lever was also stiff, it zoomed to the extreme every time it was touched because it couldn't return to the centre position when released due to gunk. I again held the camera upside down and very carefully squirted a drop of WD40 around the centre of the lever and quickly wiped off the excess. That now works as well.


I may have to take the cover off the camera to do a permanent repair, a youtube link on stripping is here:

go to 5:40 mark for begin strip.
Just thought this may help someone.



Hello Folks...

A welcome respite - i had approached the Canon service center in India & enquired about this problem. They were totally unaware of the problem. However, they did admit that there is a flaw in the HIgh Res version of S100 & hence Canon is offering a free repair.


SInce my S100(normal version) is out of warranty, i decided to give it a try. They inspected it & told me that the PC assembly was defective - picture attached. The current was not flowing from one end to the other end. This part was replaced for about $10. The inspection & repair service chage is about $18. So, for a total of about $30, i have a camera that works fine now.  The costing might vary in different countries - this was my experience at Canon center in Bangalore, INDIA


Got it done in 3 days 🙂

Need to check how many days will this work!




Sorry - its not PC .

It is FPC assembly that was defective. This part is located below the shutter release button.

Item code CM1 -7226 - 000

click here to view the gallery