cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100

sandysorlien
Apprentice

Hello,

I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Uh the camera is all foggy now is this normal??

Wow, how did you think to blow the side of your camera...? My S100 is taking photos again. I am not joking. Not going to lie I honestly thought you made a joke post here (sorry) but I was willing to try it :). It's slowly de-fogging and hopefully once it's totally unfogs it can take photos again. And how is this working now in the first place? I am utterly confused and also quite happy you posted your solution here. There's hope for the sad S100 owners of this forum!!

Oh my lordy. I did exactly as socaljd suggested. A couple of big huffs and the camera fogged up totally. I left the lens extended and took the battery out. Let it all de-fog for half an hour. And now my S100 is working again. It's only been a few hours....but so far so good. Remarkable. THANKS SOCALJD!!!!!!!!!!!!!

I left mine to defog. Turned it on and it was still having the same problem for the first 5s but then took photos after... So definitely much better than its previous situation!!

I'll keep you updated as I'm going to take my s100 again for a test run this week.

Others: would be curious if the solution works for you???

Hey Ian, does your s100 work? I gave it a few hours rest and it is not working again! 😞

I tried to give it a few huffs again and now it works. So I'm guessing I'll have to do this everytime to get the S100 to work? It's kind of funny! I suppose I'll just have to do this everytime I embark on a new trip 😛 This is going to be very hard to take spontaneous pictures...

Touch wood, it's still working. One kiss of life is all mine required

lol !! I will refrain from all the jokes that come to mind with this fix !!

So glad for all you people you have a cure for it !!

fourteen days and counting since my totally dysfunctional S100 has been up and performing as new. Even so, I will not call the process,(BJ), a FIX! I have, though, taken 614 pictures in that period of time without as much as a hint of the shutter problem. That's good! I'm beginning to rely on the camera. That's bad! It would be helpful if any other photo friends, that dare try this unorthodox method, report their results. (good or bad!)
socaljd

So .. I thought I'd give this a try (nothing to lose eh?) and went to retrieve my S100 from the basement. After taking about 100 pictures the error just isn't there anymore. I wonder if it's the humidity that's actually fixing the problem, as it's quite humid in my basement and the camera has been down there for a few months.

I think the flexible printed cicuit board that holds the switch buckled perhaps and by blowing into it it has buckled back up again where it's suppose to be. Kind of snapped it back in to place.

Of course anything is possible and if it was hunidity related it will act up again, but I still think it is what I said above or some form of that.

If all you have to do to fix it is blow it and save repair costs then what harm is a blow job fix between camera and owner! lol

What happens in the camera bag stays in the camera bag !! lol

Avatar
click here to view the gallery
Announcements