Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

I LOL-ed so hard at your post. Nice fix name 🙂

My S100 stopped working again. But after a quick puff, it's now operational again. I guess this is one of those "one weird tricks" the interwebs is always talking about

lets see if Canon posts this fix a the "solution" !!  lol

John - would it be something like this?

Fellow S100 owners,

we have found a temporary fix to the "shutter release" problem that many of you have discovered. While we currently do not have a program to enable repairs free of charge, we do have a solution that is. Simply blow into your camera and your S100 will be working like new.

I think whoever will write this if they ever, will have quite a lot of fun.

LOL maybe they will suplly free lipstick to enhance the fix !!!

Would you use it if they supplied free lipstick?

Let me see if I've got this straight... tronnebonne's driving down the street and this motorcycle cop sees him weaving a tad while he's is blowing on the side of his tiny little camera til his face is red. Is that the picture? He explains he is giving a "BJ' to his Canon. The officer of the law starts laughing so hard he cannot administer a field sobriety test and tronnbonne walks! What ever you do, tronnebonne, do not tell anyone it was my crazy idea! However, over 2 weeks and 753 pictures with NO PROBLEMS! Only one clearing out the S100's sinuses. Life be good!

SocalJd - I will SO tell the officer it was your idea. 🙂

SoclaJD, single-handedly responsible for "curious" behaviors between human life form and S100.

Hey Ian, so if I'm understanding this correctly, you already gave it a quick "puff" and it was working. Then you left it alone for a few hours and your S100 *wasn't* operational right?

Not until you give it a hard "puff" then it is operational again?

Because this is the exact situation I'm in.

Correct Tronnebonne: A couple of big puffs fogged up the dead camera, but after it de-fogged it was perfectly operational for a couple days. I tried it again this morning and it would not take photos. I gave it another puff and voila. Working again.

Enter for a chance to win