cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

G15 Black Screen

mrbenstevenson
Apprentice

My screen has gone completely black, it lights up when I turn it on so it is still functioning but not displaying any image. I am under impression that resetting the camera will fix this, is there a way to reset it without being able to see the menu navigation?

 

Thanks

8 REPLIES 8

John_
Authority

You can try using the AV out port and hook it to a tv or monitor...Im not sure if the menus will diplay but it's more a try.

Also you can try removing the battery and the date/time button battery then holding down the power switch for at least 45 seconds.

Have you tried pressing the display switche to toggle thru the display option too?

Thanks John, I will try an AV link & removing all batteries. No luck with the display switch button. 

I have same problem  . Any help would be appreciated  Elph 110

brianjoan
Contributor

I hae the same problem.  Did you fix it and if so how?

agirlhasnoname
Apprentice

@mrbenstevenson wrote:

My screen has gone completely black, it lights up when I turn it on so it is still functioning but not displaying any image.


Happened out of the blue - whilst Im sure there will be a service mode button press somewhere, I couldn't find reference to it. So I had output via HDMI, put a in blank card, the camera was taking pictures and there was playback too on the remote screen, just nothing on the back of the camera, no menus, but there was a hint of backlight. Hmm. Still could be a lockup in the display section. the "Reset all menus" did not bring it back.

 

Given that there was nothing traumatic that had happened to the camera, after searching the net, I found a disassembly guide for the G16 on ifixit. As its later sibling, they share the same display, so at a whim it was decided to pull it apart. The disassembly instructions for the G16 almost matched the G15 - only difference was there are two less screws to take out, and the small menu/control board cable locks into a different spot, but otherwise it is substantially the same.

 

I disconnected the LCD display from the camera just as if I was going to replace it, then carefully reconnected it and put the control/menu board back in place. Whatever that did, the screen came to life again when I put the battery back in.

 

You can only try.  & I have no idea why or what happened, but it came back. Hope this may help someone else

THANK YOU SO MUCH!!! One of our company cameras, a Powershot G15 had the same problem. I was able to follow the iFixit G16 disassembly instructions. I then unplugged and re-plugged the display, and voila! IT WORKED. Saved us a lot of money in repairs or replacement. Only took about 30 minutes. AND my co-workers think I'm a friggin genius! Thanks again! Most grateful.

Nicolaslf16
Apprentice
This comment helped me a lot.

Had a G15 for the past 5 years and in 2016 my camera fell from a cheap tripod and the screen went black.

I still took pictures, and continued the session as well. But I never touched the camera again.

Till today, when I read your entry, I had the same issue.

Black screen, nothing else.

I decided to pull it apart and try to disconnect-connect the screen. Thank God I had a guide from where to start.

I had nothing to lose, right?

So I ended up reviving my camera and I'm happy I can take photos and record videos again naturally.

My relief was just so big, thanks so much for this entry, it saved my life.

Nick.

Timothy333
Apprentice

@mrbenstevenson wrote:

My screen has gone completely black, kodi it lights up when I turn it on so it is still functioning but not displaying any image. I am under impression that resetting the camera will fix this, is there a way to reset it without being able to see the menu navigation?

 

Thanks


I think I am also facing this issue. Did you get any proper solution?

Avatar
click here to view the gallery
Announcements