cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon g7x mark ii Firmware not listed on set up menu

ayyy
Apprentice

There is no firmware option in my setup menu, making it impossible to send photos to image.canon. I have already tried switching the mode to a creative modes (P, Av, etc.) and playback mode, but it is still not coming up on my menu. 

 
1 ACCEPTED SOLUTION

Shadowsports and 5Div, thanks for your help in trying to solve my issue. I finally solved my problem, by doing 2 things differently. Not sure which did it, but in the event others run into this problem the firmware option did not turn up for me until I

A. Used a Different Card and B. Used a different reader to install firmware on the card. My inclination is think that it was the using a different card.

View solution in original post

18 REPLIES 18

Anonymous
Not applicable

You have to turn the camera on using the playback button (right facing arrow) not the power button in order to see the firmware update menu.

Anonymous
Not applicable

Why do you need to update the firmware to send photos to your computer? I recommend using a card reader to copy photo files to your computer.

Anonymous
Not applicable

Turn the camera off. Then press the playback button. You cannot use the power button if you want to see the firmware update menu.

Thank you!

Anonymous
Not applicable

You're welcome.

shadowsports
Legend
Legend

Ayyy,

5DIV is correct about using the playback button versus the power button in order for the firmware update menu to display.

On supported devices, updated firmware is required to utilize image.canon service whether using the image.canon app on a mobile device or your PC.  

 

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It

jpcaruso
Apprentice

Hi, I am having the same issue and for the life of me can't figure it out. I am certain that I my camera is powered off.  I am also making sure that I am just pressing the button only, then the menu, but my menus do not have anything listed for firmware.  To complicate things, some times when I do the above, I receive the following menu, and others, I see the menu in the second picture. Neither have a mention of firmware. (I want to reiterate - the power is off, I press the playback button with the arrow next to menu is point to the left, and then I press menu. My assumption is that I have the C7X Mark II original firmware.IMG_0045.jpgIMG_0041.jpg

 

Anonymous
Not applicable

Which button are you pressing? From camera powered off, press only the playback button (has a right facing triangle on it). Do you have a G7x Mark II camera?

G7X Mark II - Yes -- Camera off -> Press the playback button -> then menu - pictured below. IMG_0046.jpg

 

Avatar
click here to view the press release
Announcements