Showing results for 
Show  only  | Search instead for 
Did you mean: 

PowerShot G7 X Mark II firmware update option missing from menu


I have been searching for a way to upgrade my G7X to the latest firmware. I see there is a post regarding this here:

The issue that is not mentioned is that the G7X does not have a "firmware update" in the tools menu. It doesn't exist. I believe I read somewhere that the only way is through a piece of Canon software, but I am trying to confirm this.

I have followed everything on the thread mentioned above, but as I said, when I put the SD car din the camera and to on the playback mode and look at the tools menu, there is no firmware update selection.




I am reading that it might be due to the type of SD card and/or card reader/writer. I think the "update firmware" selection ONLY appears if the camera sees a properly formatted version of firmware in the SD slot?

I will try a different SD card, not sure if I have a different read, but I can try it through a PC rather than my Mac

It may be due to your camera not being in the correct mode.  Try switching it to either Program (P) or Manual (M) mode and see if the firmware menu now shows up.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers


It doesn't show up in "P" or "M" mode


I have now tried the following:
  1. Used three different SD cards. Two SanDisk and One Kingston.
  2. Used an external SD card reader (MacOS), used a card reader that is built into a laptop (Mac) and a second card reader on a PC (instead of a Mac)
  3. Set the camera to "P" mode and to "M" mode
The firmware install toggle never appears.


OMG, it just worked! I was looking at the wrong menu? I thought is was in the tools menu, but it is in the playback (blue) menu. I hope that anyone reading through this will get a heads up.