Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mf644cdw no longer scans


This scanner used to scan fine on my old computer. On my new computer, I installed the drivers, but when I try to scan a document either w/the sheet feeder or flatbed, it says, "Scanning" but nothing happens. I *am* able to scan through Photoshop and it prints fine.


I tried to update the firmware but it says, "communication error."


thanks for your help.




Hi dtrachtman,


Welcome to the Canon Forums and thanks for your post!


Thank you for your inquiry, and welcome to the Canon Forums. We appreciate your participation, however, for the community to best assist you can you provide us with the following information:

1. Operating System of the computer?


2. How is your printer connected?

3. Can you scan using MF ScanGear?


4. Any anti-virus program on computer? If so, what is the name?


Any other details you'd like to give will only help the Community better understand your issue!


If this is a time-sensitive matter, our US-based technical support team is standing by at 1-800-OK-CANON (1-800-652-2666) weekdays between 10 AM and 6:30 PM ET.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well


I am running Windows 10 Home, connected via USB, I have not tried MF Scangear but don't want to install additional software on my computer if I can avoid it. The antivirus software is Kaspersky. That also is the same as was on my old computer.


thanks in advance



Thank you for the information. Turn off the computer and printer. Disconnect and reconnect the USB cable from the printer AND computer. Turn back on the computer and when finish booting up then turn on the printer. Please disable any program running in the background. Try to scan again.


If the issue continues, please answer these questions:


How old and long is the USB cable?

Is the printer connected directly to the USB port of the Windows 10 computer?


Also, our support is available at 1-800-OK-CANON (1-800-652-2666) Monday-Friday from 10:00 am to 6:30 pm ET, excluding holidays.


 Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well. 

I did those things to no avail. It is prob an old cable, a few ft. I guess I have to call tech support 😞

I have tried calling tech support but it says the hold time is "longer than 50minutes." I can't wait that long. Can noone help?

Hello Dtrachtman,


If you are trying to scan and it is just processing it does look like something is blocking the connection or there is software missing. The MFtoolbox would be the main scanner software for the MF642Cdw. Without the toolbox, you will not be able to scan using the operation panel on the MF644. If you do not have the toolbox installed, you can download and install it using the link below. You can locate the MFtoolbox under the software tab on the page.


Once it has finished the installation you can try the scan again to see if it works or if you get any errors. If it still does not work, you can turn Kaspersky off and you can try scanning again.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th