Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox Cannot communicate with the scanner - I may have found root cause and fix


Sometime within the past week, MF Toolbox stopped working on my desktop with the following error message.


Cannot communicate with the scanner.

The cable may be disconnected , or the scanner may be turned off.

Check the scanner status and try again.

Scanner driver will be terminated.


A temporary fix is to run MF Toolbox as administrator, but I wanted to find the root cause of this issue and fix it for good.


The first thing I did was create a new user account on my machine and try running MF toolbox from that user account. 

This worked, narrowing the problem down to an issue with the user account.


I traced the problem to the following registry key:




I checked the permissions on the key and everything was in order.  I then tried temporarily renaming the key and that fixed the issue.  MF Toolbox started working perfectly again.  Removing this key is not a solution though since it and its contents are needed.  


I renamed the key back to its original name and the problem came back.  MF Toolbox would no longer work unless I ran as administrator.


I spend several hours messing with the permissions on the key, removing and readding individual nodes in the key, etc. and came to the conclusion that, for some reason, the very existance of the key was causing MF Toolbox to fail.


Finally, I exported the key to a file.  Deleted the key, and then reimported it from the file I had just created.  I then adjusted the permissions on the newely imported key to make sure it was exactly as it was before.  After doing this, MF toolbox works perfectly again.


The only conclusion I can come up with is that there was some type of corruption or some other issue with this registry key that could not be seen in the Registry Editor.  Whatever it was, exporting and reimporting tthe key fixed the issue with MF Toolbox.