cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageCLASS LBP622Cdw Won't Show Up After Ventura V13 Update

rhodesfilm
Apprentice

I just upgraded to Ventura V13. I downloaded the update from the Canon website, restarted my computer and the printer will not show up in System Settings (Add Printer). I've tried various recommendations but still no way to add the printer to the list. Any suggestions?

I'm using a MacBook Pro 2021.

Thank you!

1 ACCEPTED SOLUTION

Hello Rhodesfilm,

If the printer does not appear in the add printer window after you click + at the bottom of the printer list. It will mean the Mac is unable to detect network connection for the printer. In this situation you can verify that the Mac can get to the printer's remote UI by using the steps in the link HERE.

If the Mac is unable to get to the remote UI, you can check if both devices are on the same network or reconnecting the printer to the wifi. You can also try unplugging the router that is connecting the devices for 5 seconds and then plugging it back in. Once the network is back up, you can click on the apple in the upper left hand corner of the screen and then click on system preferences. Once in system preferences click on Printers and Scanners. You can click the + at the bottom of the printer list to see if the printer appears as an option to add. 

If the printer is still not showing up, you can try connecting the printer to the Mac via USB to see if it appears in the list and you can add it. If you continue to have issue, I would suggest contacting support over the phone at 1-800-652-2666. Our agents would be happy to assist.

 

View solution in original post

4 REPLIES 4

Danny
Moderator
Moderator

Hi, rhodesfilm!

So that the Community can help you better, we need to know whether your printer is communicating with your printer via Wi-Fi or via a USB cable. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

rhodesfilm
Apprentice

Hi, thank you for responding. 

I am using WiFi. I walked myself through the Canon online video again to make sure I was connecting my router and password correctly. 

The Ventura driver download from the Canon website seems to have installed properly. My settings are correct in the machine for my WiFi, however, when I go to add the printer in Systems Settings, it won't show up at all.

I seem to have a problem about every other update. I have an HP as back up in case my Canon has an issue. On Monterey, the Canon printer worked and the HP didn't. On Ventura, it switched. 

What other info do you need? Let me know. I have been going back through the community boards looking for answers but nothing yet.

Thank you!

Hello Rhodesfilm,

If the printer does not appear in the add printer window after you click + at the bottom of the printer list. It will mean the Mac is unable to detect network connection for the printer. In this situation you can verify that the Mac can get to the printer's remote UI by using the steps in the link HERE.

If the Mac is unable to get to the remote UI, you can check if both devices are on the same network or reconnecting the printer to the wifi. You can also try unplugging the router that is connecting the devices for 5 seconds and then plugging it back in. Once the network is back up, you can click on the apple in the upper left hand corner of the screen and then click on system preferences. Once in system preferences click on Printers and Scanners. You can click the + at the bottom of the printer list to see if the printer appears as an option to add. 

If the printer is still not showing up, you can try connecting the printer to the Mac via USB to see if it appears in the list and you can add it. If you continue to have issue, I would suggest contacting support over the phone at 1-800-652-2666. Our agents would be happy to assist.

 

Thank you Hector!

I tried a couple of things for the UI link you gave me. I'm not sure what happened but my printer finally also updated its firmware. That was probably much of the problem. I wish I could explain in more detail what I did for others but at some point it just all connected. I appreciate the help.

Avatar
click here to view the press release
Announcements