Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility + Apple Silicon / M1 Mac


EOS Webcam Utility doesn't work with apps like Google Chrome with M1 Macs, but it should be able to easily with some help from Canon.

I recently switched to an M1 powered Macbook Pro from an Intel one and noticed that after installing the utility, it didn't show up as an available camera. Doing some internet searching including on this forum I found the following advice:
1. Use OBS Studio as a virtual camera.
2. Use the x86 version of Google Chrome in Rosetta

Neither of these are a great option though as running OBS is purely band-aid and the x86 version of Chrome in Rosetta has a massive performance hit for me on my machine.

So I decided to do some debugging as to why it wasn't working. (Why does it work in OBS and perhaps some other places but not in Chrome) and it's actually really simple:

Error loading /Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility: dlopen(/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility, 0x0106): tried: '/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility' (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e)))

Chrome (and probably other apps) bail out when they try and grab the device because EWCService / the CoreMediaIO DAL plugin is compiled for x86 instead of ARM.

I don't have access to the source code (the community would help with these issues if you open-sourced it Canon btw 😉) which limits my ability to go further, but my strong theory is without much work if the existing EOS Webcam Utility for Mac was just compiled / available for ARM then it'd work with a bunch more apps. It could be as simple as changing the build target.

Is there a place we can write up tickets for the EOS Webcam Utility team?


EOS webcam utility was released in Asia for Mac silicon. I downloaded this update for my M1 Max and now EOS integration works fine. Nevermind the won't-solve post.

View solution in original post


You make it sound like they are given away free of charge.  They are not.  You had to pay for a $500 license and buy a pre-release M1 Mac.  No doubt an enterprise or multi-user license would cost significantly more. 

I am familiar with how Apple has operated in the past when it comes to software development.  Unlike developing for Windows, which has an entry level that is free of charge, you have to buy everything from Apple.  When it comes to publish your application, you have to buy another type of license, which must be periodically renewed.

"The right mouse button is your friend."

What does that have to do with this? I’m sure a 26 billion dollar corporation like Canon can afford any development tool and computers they need for whatever platform they want to develop for.


Right now the only solution is Cascable Pro. We were in bit of a panic as we stream weekly and when we upgraded from an intel iMac to an M1 iMac WebCam utility no longer worked.

This works for me.Image 2023-09-15 at 9.29 PM.jpg


Do you have tried webcam utility with the new OBS 28.0.2 for Apple Silicon?

For us it does not work with OBS on our M1 iMac. Cascable Pro works well. We connect wirelessly to a 6D Mk II.

I've seen this solution offered but it isn't working for me. 


One "workaround" is to download and install the free streaming software OBS.  It recognizes EOS Webcam Utility camera (you may need to shutdown EOS Utility 3 first), and with OBS's virtual camera started, it presents an OBS Virtual Camera video source to other apps.  This seems to work on my M1 Silicon Chip MacBook Pro running macOS Monterey.



This worked for me / is the right answer. Just pay attention to top comment on the youtube video. You have to download the OBS version for Intel not M1. EOS Webcam Utility (intel) + OSB (intel) led to success on M1 Max for me. Hope this helps other folks. "Accepted Answer" that this will not work is contrary to my experience.

I couldn't get that working with FaceTime.   Other apps, yes.  Not FaceTime.

Cascable Pro Webcam works for me, but not OBS.

click here to view the gallery