cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Windows 10 download killed all my Canon Rebel T5 softwear. Can't even download pix from camera.

lorenbliss
Apprentice

Convinced by Microshaft to "upgrade" from Windows 8.1,  the most recent Windows 10  update has rendered all my photo softwear -- Canon and GIMP alike -- unoperational. Everything was working fine until this most recent update, but now can't  even download pictures from the camera to the computer.  Please help.

 

 

(NOTE: This is by no means the first problem inflicted by Windows 10. It temporarily shut down my Norton anti-virus, nearly did in my email client [Thunderbird], also caused problems with my browser [Firefox]  and printer [HP Envy 5530]. Many many others report similar problems. Hence it's obvious Microshaft is again violating the anti-trust laws, trying to put everybody else out of business.)

10 REPLIES 10

Tim
Authority

Hello Lorenbliss, 

You may need to download more recent versions of your applications to resolve this issue.  You can do so through Canon's web site, here.  You will need the serial number of your camera in order to download this software.  

If we could, Click Here to be directed.  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

TCampbell
Elite

You can get updated versions of the software from Canon's product page, located here:

 

http://usa.canon.com/cusa/consumer/products/cameras/slr_cameras/eos_rebel_t5_18_55_is_ii_kit#Drivers...

 

The Canon software does not have a feature to check for updates... so you should probably bookmark the page and check back from time to time.  Currently Canon has updates for Windows 10 for three of the components.

 

  • EOS Utility
  • Digital Photo Professional
  • Picture Style Editor

  

EOS Utility and DPP are probably the most important.

 

Tim Campbell
5D III, 5D IV, 60Da

I tried this and it still doesn't work.

this didn't work.

A separate card reader (fairly inexpensive) will d/l any and all.  No matter what Windows version you have or what camera. If you use Raw you may need additional codex's to view but you need nothing for jpg.

EB
EOS 1DX and 1D Mk IV and several lenses!

jhansen2016
Contributor
My question is how did you even manage to install that software to begin with. I've had my Camera for a week and no matter what I do, I get an install error when I run the Solutions Disk.

Hi jhansen2016,

 

Thanks for posting.

 

Just to ensure that we're looking at the same products and software, please let us know if you're also using an EOS Rebel T5 and if you're using a Windows 10 computer.

 

When you receive an error with the disk installation, are you receiving that when installing a CD-ROM, included with your camera or from the software from our website?

 

Finally, what error message are you receiving?

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

jrhoffman75
Legend
Your solution disk might be pre-W10.

Did you try downloading the digital image of the disk I pointed you to in your other post?
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

basskerrie
Apprentice

This stil doesn't work for me.

 

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.