Showing results for 
Search instead for 
Did you mean: 

Rebel t6i not recognized by computer

I have downloaded the eos utility but when I plug my camera in to my laptop it doesn't recognize it. I am trying to get pictures from camera to computer.
This is first time trying to do so and on a laptop and just installed Windows 10


Do you have Windows 10 N installed? If so, it means No Media Player.


You can download the W10 media Player for free from the Microsoft website.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic


When the camera is connected via USB, the EOS Utility launcher should startup, detect what type of camera you have, and then launch either EOS Utility 2, or EOS Utility 3.  Be sure to turn on the camera power switch after you connect via USB.


In some cases, the EOS Utility will try to launch the Wi-Fi utility and stop.  Is this what you are seeing?

"The right mouse button is your friend."

When I plug in via usb it does not open the utility. It does nothing. I then open the utility myself but then it just shows connect via wifi. But doesn't recognize camera either

I suggest calling Canon Support at 1-800-OK-CANON.


However, I have experienced the same issue with cameras with built-in Wi-Fi.  The Utility Launcher wants to default to the Wi-Fi utility, instead of the conventional USB connection.  Try going into the Windows Start menu....look for the "Canon Utilities" folder, and manually launch the EOS3 utility.  You will see more than one of them, but only one will launch the USB version..  Once a connection is established, the Utility Launcher should recognize your camera, and launch the prevously used utility....via USB.

"The right mouse button is your friend."


WiFi pairing is initiated on the camera LCD menu, you need to choose EOS Utility as the type of connection, then follow the steps on the camera menu to configure the network settings. Near the end of the process the camera prompts you to start the pairing software on your computer, this is your cue to run EOS Utility.

With the release of EOS Utility 3.0 Canon has changed the process for WiFi pairing your EOS camera with your computer. Canon has added an EOS Utility Launcher that will start if you try to run EOS Utility when no cameras are connected to the computer with USB. The software assumes that no connected cameras means that you will connect a camera with WiFi.


If you disable wifi and reconnect the USB you should be fine.

EOS 1DX and 1D Mk IV and several lenses!

Ok so I finally had a chance to look into this. The first thing I tried was to disable the wifi on my camera menu and then it finally recognized my camera 🙂 I can now download my images! Thank you all for your help!


After several months of spending what time I could spend googling and searching through all of the complaints and explanations that I could find as to why EOS Utilities would not recognize my T6i, and using trial and error on my own ideas of why, I finally figured it out.  You have to do things in a specific order to keep connection long enough to get your camera connected to the EOS Utilities long enough to connect the camera to other devices.  A few weeks or so after buying the camera, I made the mistake, while I was away from home with my camera and getting in a hurry to post pictures, of connecting my camera to my cell phone and loaded pictures onto Facebook.  I had not had much time for doing much else previously with the camera but taking pictures and connecting it to the computer and downloading the pictures and videos to a flash drive via the computer and then sharing from my computer.  After connecting my camera to the cell phone, the next time I got ready to download my pictures to a flash drive via the computer, the Cannon Utilities would not recognize my camera any longer.  After messing with it for a while, I wandered if my connecting the camera to the phone had something to do with it and I kept googling how to fix the situation.  But, nothing that I found solved the situation.  After several weeks of searching for the answer during my spare time, I finally went to the reset the camera connection by enabling the Wi-fi/NFC and then going to Wi-Fi function and choosing the camera icon.  I then I chose GENERAL SETTING  and then I chose CLEAR WIFI SETTINGS and I set my camera back to default.  I then turned off the camera, the computer, the Wi-Fi, and the internet for a while to make sure all connections were thoroughly disconnected.  I then logged the internet, Wi-Fi, and then computer back on again.  I connected my camera to the computer with the interface cable.  I turned the camera on and click on the EOS Utility icon on my desktop which brought it up.  It had choice that said something to the effect of connect by LAN or CLOSE and I clicked on the connect by LAN, or whatever that connect t choice stated. I then clicked on the start menu on my computer and chose EOS WEB SERVICE REGISTRATION TOOL.  I followed the instructions that I had found on the canon web sites that I had googled on how to register your camera to Canon Image Gateway, Facebook and such.  I made sure that the Nickname I gave for my camera was the same as the one I had given previously for the cell phone nickname connection.  I register for the Gateway, Facebook and such and then transferred to the connections to the camera side of the form as per the instructions.  Then after completing that task, I disconnected from the function and went to the room where my Wi-Fi station was connect to my internet and went into the menu on my camera and went back into the Wi-Fi connections on my camera screen.  I chose the globe setting for connecting to the Wi-Fi and followed the instructions to select the WPS and connect using the WPS button on my Netgar Wi-Fi for each of the Gateway and Facebook.  After getting all of that set up, I disconnect and started all over again connecting my cell phone to the camera again while making sure the camera nick names were the same.

06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM