Showing results for 
Show  only  | Search instead for 
Did you mean: 

Help! Images taken on a Canon EOS 2000D won't display on camera and can't be downloaded


I took a load of photos yesterday using a memory card.  Half of the images are fine but the others, despite there being something there as they are all substantial file sizes, won't display or download.  It says the format is not supported!

I'm so upset at the photos were for work and I am going to be in all sorts of trouble without them.  I have tried downloading with the Canon app, also with my laptop.  How can I try to rescue the images and get them? 




What are the file extensions of the files that you can't display?

What is the method you used to try and download them?

Steve Thomas

They are all jpeg files…..I first tried to download them on my canon app on an ipad, then via my apple Mac using the memory card in a usb thing.  Both cards have the same problem but I know that when I took the photo it showed in the display on the camera as a ‘taken’ shot! 

Can you use your card reader and show us a Finder "get Info" display on one of the bad files?

I’ve probably done it wrong but it just gives the name of the file, nothing else. It is the same with the images on the card that are showing. 


What camera?

What Computer?

Do the images display on the camera?

Is it a full size card or micro with adapter?

Do you have a card reader?

How did you download the images?

The images aren’t displaying on the camera but they were there directly after I took each photo. 

The oddest thing is some pictures are saved and showing, just the vast majority are not.  The camera is a Canon EOS 2000D and I have tried downloading them all different ways 

If you can't display them on the camera, it is likely that the memory card is corrupted. Again, was this a full size card or micro with adapter? When was the last time you formatted the card in the camera?

I formatted it yesterday before using. It is a full size card! 

Can corrupted memory cards be fixed?