Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS r6: Firmware 1.5 dmg file will not open under MacOS 12.01


Hi Everyone,

I'm new here and posting for the first time.  I have a Canon EOS r6 and was trying to update the firmware to version 1.5.  I successfully downloaded the firmware from Canon site, but when I try to open the dmg file on my Mac, both M1 and Intel units (both have MacOS 12.01 Monterey), the dmg file will not open.  

On the canon site, I had to choose MacOS 11 just to download the file.  It seems that Canon released the firmware without support for MacOS 12 Monterey.  

Has anyone else experienced this or has successfully update their EOS R5/R6 cameras using MacOS 12.01?

Thanks for your help.


You need to look under Finder preferences, general.  You should see a popup like this.  Once you click on hard disk, it will appear on your desktop.


Screen Shot 2021-12-07 at 9.14.34 AM.png

View solution in original post

SOLVED:  I called Canon - they suggested i try the zip file instead. That worked like a charm.

View solution in original post



Did you ever resolve this or get an answer?  I'm having the same problem four months after you wrote your question.

I'm trying to upgrade my firmware to 1.52 and it will not mount again.  I'm running Intel MacOS 12.3.1.  On the finder preferences, I have everything check off including Hard Drive, still not mounting.  Anyone else having this issue.

Problem resolved.  the following needs to be done in the Finder Preferences->General



Having the same problem again with new firmware. Amazing that Canon don't allow you to update on a Mac!


Product Expert
Product Expert

Hi fpelletier,

Looking at the comment chain are you still having the issue with the .dmg file not opening? The firmware file should be able to open in OS 12 with Intel or M1 chips. If it still isn't opening one more thing to try would be to bring up the file directly in Finder. When you bring it up switch Finder to either column or list view, navigate to the .dmg file, and when you open it the contents should be listed below or to the side of the .dmg file. 

I also see a Me Too note under your post about the camera not reading the firmware update. 

There are a few things to check when updating the firmware. When you transfer the firmware file to your SD card you only transfer the file ending in .fir. If you transferred anything else the camera will not be able to read it. The only one that should be put on the memory card is the .fir file.

The other thing is to double check the location of the .fir file on the memory card. If it is in the root folder it should be listed with the DCIM and MISC folders on the memory card. If it is inside of either of those folders the camera will not be able to read it. Instructions on checking those two items are included in with the firmware file you downloaded. In the folder will be the .fir file and a folder with the instructions.


I tested on MBP, M1.  Ventura.  No issues opening .dmg

FYI FW v1.7.0 for the R6 is available as of 12-7-2022

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

That is very odd that it would work on your M1 but not on mine that has the exact same specs.    I have opened other .dmg files with no problems but the ones from Canon don't open.   Computers ughhhhhh!!!!!!


It appears on desktop but doesn't decompress when double clicked

A .DMG file is an executable.  It does mount and will appear on your desktop when clicked as long as you have hard disk selected in Finder preferences.  You then copy the .FIR file to the root of your SD card to perform the firmware update.  

This difference was caused by changes Apple made to it's OS.  The CPU type M series or Intel does not matter.  You just need to enable the hard disk option in Finder before clicking the .DMG file.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi Rick, I appreciate your confidence in your answer but i still have not gotten the .dmg to mount despite doing all the things. Hard disk is clicked and it does NOT mount. M1 Max running 13.2.1.