cancel
Showing results for 
Search instead for 
Did you mean: 

EOS r6: Firmware 1.5 dmg file will not open under MacOS 12.01

fpelletier
New Contributor

Hi Everyone,

I'm new here and posting for the first time.  I have a Canon EOS r6 and was trying to update the firmware to version 1.5.  I successfully downloaded the firmware from Canon site, but when I try to open the dmg file on my Mac, both M1 and Intel units (both have MacOS 12.01 Monterey), the dmg file will not open.  

On the canon site, I had to choose MacOS 11 just to download the file.  It seems that Canon released the firmware without support for MacOS 12 Monterey.  

Has anyone else experienced this or has successfully update their EOS R5/R6 cameras using MacOS 12.01?

Thanks for your help.

7 REPLIES 7

rs-eos
Reputable Contributor

I don't have an R6, but I was able to both download and mount Canon's eosr6-v150-mac.dmg file on my iMac Pro (Intel) with macOS 12.0.1.  I did note that mounting the disk image file didn't automatically create a Finder window for it.  So are you sure it's not mounting for you?  Do you see a "eos6-v150-mac" icon on your desktop?

If your Mac isn't configured to show disks in Finder, go to Finder | Preferences.  Then under the "General" section, ensure that "Hard Disks" is checked (enabled).

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS

fpelletier
New Contributor

Thank you so much, its the first time that a finder window did not appear so I assumed it did not mount the disk.  On my intel Mac, yes, it is on the desktop.  However, on my M1 Mac, it is not.  My first attempt was on my M1 Mac and when that failed, I tried it on the Intel Mac.  It showed the same symptom so I did not think to look on my desktop.

Now the problem is resolved.  Works on 12.01 Intel Macs only.

I'm surprised Canon does not make an effort to have this work on all Macs.  The M1's have now been around for over a year.  

Thanks again for your help.

 

asillett
Occasional Contributor

There doesn't seem to be a hard disks option visible in preferences, general

 

You need to look under Finder preferences, general.  You should see a popup like this.  Once you click on hard disk, it will appear on your desktop.

 

Screen Shot 2021-12-07 at 9.14.34 AM.png

asillett
Occasional Contributor

Ah, I was looking under system prefs. Thank you

asillett
Occasional Contributor

The .dmg file still doesn't seem to open on a double click. Nothing is showing on desktop

fpelletier
New Contributor

Correction on the M1 Mac.  I was able to mount it there also by turning on show disks in finder, which I thought was on, but was actually off.