Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS rebel T7 phone connection trouble


Last year I connected my Canon EOS rebel T7 to my iPhone, but then I lost my phone. I tried to connect my camera to my new iPhone this year, and am having no luck. I deleted the app and reset the settings. My phone will connect to the Canon wifi network, but then nothing happens. Eventually my phone just disconnects from the network. Anything else I can try? 



I had a similar problem that I think was caused by numerous iOS updates for my iPhone and/or updating to a newer iPhone.

  What solved it was deleting the profile for SET1 in the Camera and then setting up the iPhone again as I did the first time I connected the camera to my iPhone. 

Try following the steps below and see if it works:  

1) Go to the menui and WI-Fi Menu on the camera

2) Enable Wi-Fi Function and press "Set" Button

3) Toggle over to the "Connect to Smartphone" and press the Set Button

4) Toggle down to "Delete Settings" and press the Set Button

5)  Toggle or highlight "Set1" and press the Set Button (if you have other "Sets" that you don't use or don't work, maybe delete those as well.)

6)  Toggle to "OK" and press the Set Button  This should delete Set1.

7) Back all the way out and follow the instructions to connect the camera to your iPhone just like you did the first time you connected the camera to the phone.

Good luck!