cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D mark II: Weird or amateur lens flares on pictures and too much grain?

basketmoon
Apprentice

Hi, I recently got a Canon 5D Mark II from my friend and tried it out with my EF 50mm f/1.8 (not the II). Before that I was using a crop body Canon 1100D (also with the lens mentioned before) and didn't have the issues I'm about to tell you about.

 

So, I'd like to ask you to take a look at those pictures here (it's best that you download them):https://www.dropbox.com/sh/bcx2uw8e3knrtlk/AACWp5NUEq2QLsRCtFx2Uzp9a?dl=0

 

First of all, I'm an amateur in the DSLR world, how all the tech stuff works, so I was always kinda winging it. Got the full frame body, so I can change it. I know the pictures on the dropbox folder are bad, but I was testing some settings, so I didn't really care about the composition and stuff.

 

My first issue which I didn't have back on my crop body, is the sun flare. Why does it become a straight line in almost all pictures with a backlit sun? Is it because of the cheap lens, my incapability to set the right settings, or what? It's not only happening with the sun, it's all kinds of condensed lights, as you can see on the picture with a blonde short-haired girl (the street lights), and the bridge lights on the other photos. Or even in the foreground of a portrait of that guy.

 

Another thing is, I don't know, weird grain? Zoom into the shirt of the girl, and you'll see a terrible pattern of grain. And even though the ISO is high (6400) I didn't have that kind of weird pattern-ish grain on pictures from my crop 1100D with the same amount of iso. It was just a lot of grain which I was fine with.

 

Just take a look at the file named "_MG_2584.jpg". I shot it in raw and tried to lighten up the shadows. I'm fine with grain, but oh boy that pattern-ish thing is driving me crazy. Sorry it's kinda blurred on this picture but I was trying to cover it up a bit, and as I'm writing this post I don't have the access to original files. And also the night bridge photos. Even though the ISO on "5.jpg" is only 400, the grain is still there on the sky, and it's incredibily, annoyingly visible.

 

So these are my questions. What am I doing wrong with the flares, and how do I get rid of that pattern-ish grain? Is it because the camera is broken, or something in it doesn't work properly anymore, or is it the lens maybe? Should I just let it go and get used to crappy lens flares and weird grain? Maybe my editing sucks?

4 REPLIES 4

The one conspicuous problem you didn't mention is that most of the pictures are badly out of focus. Are you sure the AF/MF switch on the lens is set correctly?

 

Are you using a lens hood? that might help keep down some of the weird flare. Also, it's not a good idea (for several reasons) to point the camera into a bright sun.

 

Have you tried the camera with a different lens and compared the result? If the friend you got it from is still a friend, maybe he/she could lend you a lens to try.

 

The 5D Mark II is a bit long in the tooth. Its high-ISO performance is not that of, say, a 5D Mark III. Maybe you're expecting too much. OTOH, a sensible evaluation will be hard to make until you solve the focus problem.

Bob
Philadelphia, Pennsylvania USA

Hey Bob, thank you for replying!

I'm afraid you're right, they are pretty out of focus, but that might be because of my worn out 50mm lens. It's been through a lot, and lately I've been thinking about sending it for a check up and internal cleaning. Sometimes it loses focus just because and goes crazy with it. That's why I like to work on manual focus, and clearly I need to work on it a bit more.

 

I don't use any lens hoods, never have, as I always loved a sweet sunset flare on my portraits.

I'll keep working with that body since it's still a killer camera, but you might be right that I'm expecting way too much out of it. I'll clean the glass on the lens, try some others, and post about it in this thread!

Shot number 6 is quite well focused, at least on the fence. It isn't the focus that is causing your problem.

All lenses will flare if you include the light source in the picture but not normally in this way.

Do you have a filter fitted, if so then remove it and try again. Cleaning the lens won't make much difference.

 

For a proper evaluation of the problem you need to give us an un-edited raw file with all the exif information still attached, you can do this via dropbox.

TCampbell
Elite
Elite

That looks a very strong diffraction spike.  It could be caused by a stuck aperture blade (that would be on the lens, not the camera).  If you own a different lens and test with the other lens, you'll find you don't have any issues.

 

A property of the physics of light (specifically the wave-nature of light) is that it "bends" around edges (it doesn't travel in a straight line like many people would suspect).  This is why heavily stopping down a lens (say... f/22) and taking a picture of a pinpoint light source would cause that light to show strong diffraction spikes so it looks star-like -- and yet shooting wide-open wont have that effect.  If you were taking a night shot in a city and you wnated all the street-lights to have that star-like appearance... you'd stop down to f/22 and you'll get diffraction spikes on every light.

 

The reason I say this looks like a "stuck" blade is because you would get a diffractinon spike created by the edge of each of the blades (and on your lens there are 5 of them) and the spikes are bi-directional.  So in total we sould count 10 spikes... but in your image, you only have 2 spikes.  That suggests to me that you're having a problem with one blade sliding in and staying there for the shot while the other 4 blades are likely retracted.

 

With the lens removed from camera, all aperture blades should completely retract out to the edges and looking through the lens you should not see any obstructions.  Does it look clear when you look through the lens (off the camera body)?

 

Also... when on the camera body it normally keeps the aperture blades retracted (wide open) for focusing purposes and only stops down when you take the shot.  (you'd have to look through the front of the lens - not the viewfinder to see this).

 

If you set a moderately high f-stop (say, f/8 or f/11) and look through the front of the lens when pressing the DoF preview button, you should see the blades constrict when you press DoF preview, and retract when you release DoF preview.  

 

On a 5D II, the DoF Preview button is the small button located below the lens release button.

 

As this is the original model 50mm f/1.8 it's not worth fixing... just junk it and buy a replacement lens (the new "STM" version has a better overall build, it has a 7 blade aperture (instead of the 5 blade in your current model) and this really improves the quality of out-of-focus background blur... and it costs about the same. 

Tim Campbell
5D III, 5D IV, 60Da
Avatar
click here to view the press release
Announcements