Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra


After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.


Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

Come on Canon - get this sorted pdq. Looks like a world-wide problem. Causing real problems and holding up work/activity!!

Thanks for the tip on using Printers & Scanners under System Preferences.  This worked great for me.  Maybe even better than the old MP Navigator Software.

MX 882 Update:

Early on, many pages back someone suggested using the Canon Quick Menu for my MX 882.

It worked, and eeked out a scan one at a time accessing MP Navigator.

A recent suggestion to call Canon suppport got me to to thatm I spent 2 hours on the phone with Robert.


So, we deleted old files and reinstalled Navigator and IJ tools and everything else in the line up according to Canon guidelines.

Two hours later, an invisable file that cannot be retreived which was deleted in this process caused Quick Menu to no longer work.


Now I have nothing. Nice, helpful folks at Canon Support have NO IDEA what caused it, who dropped the ball (Apple? Canon?) but they seem darn sure that nothing will change. 

Note: MP Navigator will not work on any new Canon printers either.

All the other printers: HP, Epson etc. have working scan software w High Sierra.

Vue Scan works great. $100 gets you the program w updates for life.

My conclusion for an MX 882. Pay $100 for a new printer, or scan software. It's hard to know for sure which is better.

But Canon? Time to go. 


thanks but no text for scan on my MX885



Same problem here with a Pixma MX 882.  I've been with Canon technical support twice.  They aren't going to update these drivers.  So basically a perfectly funcitonal printer/scanner is now useless for scanning.  The only solution is to use IOS Image Capture, which takes forever to scan.    Unbelieveable that Canon won't support a 5 year old printer.  This is the last time I buy a Canon product.

This is the reply from Canon UK which I find truly shocking. An odd way to run your support, maintain customer loyalty or expect a return purchase?


”Thank you for your email and for contacting Canon. Apologies for the delay in getting back to you.

Unfortunately, Canon MG8150 is no longer supported with Mac OS 10.13 High Sierra, there will be no printer/scanner driver available for this printer, please click on the link below for more information;

There may be a workaround to use your existing MG8150 printer on OS10.13, you will require to use your Mac built-in ‘image capture’ application for scanning, click on the link below for further information;


Yours sincerely,
Naimesh Patel
Canon Services & Support

Tel: [phone number removed per forum guidelines]

Online Support

If so, ditto me! MP Navigator great scanning slides and such from the Pima - now useless!

Ditto me on MX870. If Canon does not want to provide an updated driver, how about gift card to use in buying a new multi-printer?

I had the same issue with Pixma MG8150 after upgrade to High Sierra. Just installed MP Navigator EX ver. 4.0.5 and it's resolved. Unexpectedly I have found it at Asia Support Wesite. Why  Canon is not popsting this software on all Canon support sites? I'm from Spain...


Good luck


Unfortunately this doesn't work for MX models