Showing results for 
Show  only  | Search instead for 
Did you mean: 

MP Navigator and High Sierra


After installing macOS 10.13.1 (High Sierra) MP Navigator EX 4.0 has ceased to work.


Thanks, Mark.  In the elegance stakes, that solution scores zero, I'm afraid!  Fortunately, by updating MP Navigator to v4.0.5 and reinstalling the IJ Network Tool in its latest version, all problems with my MG 6150 have been overcome.  Took me a couple of hours to sort that out and I would have hoped for an auto-update from Canon, to be honest, but the job's done, thankfully.  Hopefully this might help other sufferers.

View solution in original post

243 REPLIES 243

Thank You, this works fine for me. A simple Google-search for version "MP Navigator X 3.1.5" gave me the following link:


Canon, are you paying attention?

Connect these dots and give us updated software. It's obviously workble if your team puts in the time.

Studawg66 - It worked! Thanks ever so much! I never thought to search for an older version of the software and try it.

Glad to hear it!  It was just a hunch.  Their recommendation was upgrade to latest version, but that version doesn't work with my MX870.  So I started with the MX870 selected in their "downloads" section and kept backing down the OS from High Sierra, to Sierra, to Mavericks until it finally gave me a version of MP Navigator to install.


Worked for me, so I'm glad to hear it works for others.


BUT Canon, if you are listening, this is an EASY fix that will keep your customers from jumping ship.  Update your website to show version 3.1.5 as the latest version compatible with High Sierra and send and email to all your registered customers telling them to upgrade.  Simple as that.



Thank you as it worked for me as well on my MG6120.  How ridiculous can Canon be that the solution sits in one of theor own websites.


Makes me want to trade all my photography equipment in on a Nikon.

Great work studawg66, they should offer you a job at Canon.You are cleverer than the people in their support-team !

studawg66 -


Thanks for your tip.  It may help others to note that the approach you suggest only worked for my MX870 using a new (November 2017) iMac after I looked up what Launchpad was and launched it from there as you suggested, instead of from the Applications folder on the Dock.  After dragging the newly downloaded MP Navigator EX 3.1 icon from Launchpad to the Dock, it now also works when launched from the Dock.  In deleting the original version of MP Navigator EX 3.1, I also deleted MP Navigator EX 3.1 Opener by dragging them both to the trash from Finder. 

Thanks again for putting me back in business!

19 March 2018 from Pennsylvania, USA


Re: Your suggested work around to restore scanner function.


A 65 year old retiree here who has some tech know how but not a lot. Followed your suggestion to use Mavericks as system and download suggested version of MP Nav software.....downloaded fine, I think, but when I tried to open it, which I did using Launchpad, it would not open. I am obviously doing something wrong I am not aware of....any thoughts as to what that might be?

And thanks for putting the work around here that others have successfully used.

Wayne Baker

Bravo to studawg66 for solving the MP8xx - Navigator problem.  Newbies to this thread, I will savestudawg66 you the two hours it took me to find this 

Re: MP Navigator and High Sierra
‎12-27-2017 12:41 PM


And as for Canon ... shame on you for not providing a solution for this problem. The MX860 I have is a perfectly seviceable printer/scanner so why should i be forced to discard it or find some cumbersome workaround because you guys want us to buy new hardware.  At the very least, tell your support staff about this solution so they can tell frustrated users.  And update your softward download pages to include MP Navigator 3.1.5 for High Sierra.


Bottom line, is I will never buy another Canon product and i will repeat this story of abysmal cutomer support to anyone who ever says they are planing to buy a Canon product.

THANKS BUDDY !!!... worked for me and my MX870!!!!!

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.