Showing results for 
Show  only  | Search instead for 
Did you mean: 

MG5320 doesn't print at all


My MG5320 was working fine for over a year, now it doesn't print at all. When I send a print job, the printer goes through all the motions, sounds like it's printing, and ejects the paper, but it's blank. I've put in new cartridges (a few times), run the nozzle clean and deep clean but none of that helps. Have downlaoded and installed the latest drive,  removed and cleaned the print head (using distilled water) and still no printing.

I've hooked it up via usb connection to three different computers (Mac, Win 7, Win XP) and it behaves the same. It scans OK just doesn't print. There's no error code.

Any idea what is going on?


Too late for most of us but if my new printer goes on the blink something to try.. and after my experience with Epsom I am sticking with Canon!


This is the first search result in Google and still no solution,  so I am going to add one.

My MG5450 suddenly started showing this problem - goes through the motions but prints blank pages. I tried all the suggested fixes on the net but nothing helped. Since the cost of repair would be pretty much the same as buying a new printer,  today I bought a new MG5750. As it happens, this printer uses the exact same printhead as the old printer (but different ink cartridges - why??). So out of curiosity I took the brand new printhead out of the brand new printer and tried it in the old printer.

The MG5450 is now working perfectly again!

So the fix to this problem (in my case anyway) is REPLACE THE PRINTHEAD.

Whether it is economical to do so is up to you. I found a few sites selling them, but they were too expensive to buy in the hope they fixed the problem. And they were not genuine Canon, whereas my replacement obviously is.

One thing I noticed when I replaced the printhead. The printer ran some sort of setup routine so it must have recognised that a new printhead had been fitted. I do wonder if this might have cleared some internal status (an end of life counter maybe), and if I put the original printhead back it might still work. But I am reluctant to risk breaking it again. So I have cleaned the old printhead and put it into the new printer where it will remain unused until the old printer eventually dies for good.

I hope this helps anyone else who comes across this problem.


my MG5350 stopped working today. I have made the troubleshooting which Canon gave (which I saw here in this thread).


first thing today, I printed one page, it came out normally, except there was some white lines on print - so I cleaned the machine (using the 'setup/maintenance') like I have done earlier succesfully.

after the cleaning, the paper didn't print anymore. I goes through the machine, like if it would print, but nothing comes out. paper is blank. tried the deep cleaning option, but it didn't help.


strangely - when I print a test picture (colouring image for kids) from web browser, I get the image printed - BUT the black lines are lightly grey.


I did the 'print nozzle check pattern', and that worked very well! also the 'print the head alignment value' prints very well.

I've made the roller cleaning also.


I opened the machine, and cleaned the golden heads (like Canon adviced to someone here on this thread), those were dirty, but cleaning didn't help the situation.


EDIT: found out couple of things. on that PRINT NOZZLE, I don't have at all the first black lines printed. That means something wrong with the pigment black (biggest cassette). That black cassette is slightly damaged (doesn't make the click when adding to its place), but it keeps in its place after I push it gently. Anyway, none of the cassettes have LIGHT, which should be on if all is fine.