Showing results for 
Show  only  | Search instead for 
Did you mean: 

Getting U052 (type of printhead incorrect) on my Pixma MP610 printer).


I'm getting a U052 error message on my Pixma MP610 printer.  It reads "The type of printhead is incorrect. Install the correct printhead."  I replaced an ink cartridge that was running low, but still get that message.  I've had the printer for some time and never got that kind of message before.



I have tried everything suggested on this forum (plus the video re washing the print head, which I did) and still get the U052 message.  I am disconsolate--I loved this printer!  I would be glad to hear of any good, solid, basic printer that anyone has used for some time with no difficulties!    I have researched and researched, and they ALL seem to have plenty of "poor" and "bad" type ratings.....    😞


I have installed a QY6-0080 Printhead in my Canpn Pixma MG5350 printer. I get the message UO52 The type of printhead is incorrect. Install the correct printhead.

What do I do?

Jim Mulligan

Did you get the message U052 and then buy a new print head, and still get the same message?

I have a MX715. Great printer. Overseas for some time. Came back, and got the U052 error.

Cleaned the print head many times but still got the error.  Tried all sorts of combinations to reset.  I once got error code 6502 which was encouraging.  but now only U052.

I removed the print head and got U051, no print head.

Installed the printhead with no cartridges and got U052.

Added the cartridges still got U052.

I'll reluctantly buy a new printhead, but only if I know it will solve the problem.


Any thoughts?


Hi, has anyone discovered the fix for this. I'm about to throw my Canon Pixma MP610 away due to not being able to fix this problem.

Seems to me there is no unique solution to this absurd and unacceptable situation. I got hit by this today on my MG5250. Cleaned the print head carefully with tissue and cotton buds to remove obvious ink, reassembled, and it looked fine when I closed the cover (i.e. no U052). But when I tried to send a file for printing, back came the U052. So, repeated the procedure, but this time after reassembling I did a nozzle pattern print before attempting to send a file over: the pattern print worked fine, and so then did printing the file...


This worked for me, but, obviously, is not going to be a solution for everyone. If it happens again and is unfixable, it's bye-bye Canon.

Thats exactly what Canon is hoping we will All do. Lots of lovely new sales for Canon.
click here to view the press release