Showing results for 
Show  only  | Search instead for 
Did you mean: 

Code 5,157,69 - MG5520


I have a PIXMA MG5520 printer.  The printer works, the copier works, but when I try to scan, I get a Code 5,157,69.  I have uninstalled and reinstalled the software, but nothing seems to work.  So my guess is that there is a setting which somehow got changed.  Please help.



I was getting the same error and tried un-install / re-install, which didn't work.  Then I turned of my work VPN to see if that was the issue and it was.  As soon as I disconnected the VPN it worked again, so the first couple of times I used the scanner I must not have been on my company's VPN.  Hope that helps!

View solution in original post



I removed the printer from the system, deleted the software, rebooted the computer then re-added the printer and software and continue to have the same problem.  For the time being I'll get around it by using the "Scannable" app on my iPhone which does a great job of scanning, correcting and allows me to send the information anywhere via text or email.


I was receiving this error as well in Windows 10. I found a workaround by using the Windows Fax and Scan utility that is found under Windows Accessories in the start menu. You may have to create a new profile to get it to scan an entire page, but it works.

I found that the best solution is to quit trying to use the Canon Printer and download "Scanable" to your iPhone.   It is an easy-to-use application, will align and clean up the item and you can easily email or text it as needed.  When I need something scanned now I use "Scanable" then email it to myself and store it on the computer or print it directly from my phone using airprint. I've given up on trying to get the Canon scanner to work with Windows 10.   For some reason the Windows 10 just blocks the scanner regardless of what steps are taken to reload or allow it access.

I had the same error: the problem was, that a mac scanner utility was connected to the scanner already and my wife tried to scan on another windows machine. So if you get this error, check for other (mac) devices.


After much research, I think that I have finally found a solution that worked for me.  I have MX490 on Windows 10.  When I did the Paint test, listed above, it gave me 2 different scanning options for the same system.  Here is what I believe happened.  When I used Windows plug and play to add a device it created a  generic driver system.  Then, I downloaded the actual drivers from Canon. That created another device and driver system for the same scanner.  Having 2 drivers for the same system does not work.  I believe that the combating drivers/software is when you get the error message "system cannot connect because another user or program is using the system".  This is one of the issues I had, along with the error codes in this feed.


So, Here is my solution:

click Start/search

click Control Panel

click or search for Device Manager

click Imaging Devices

single click and hi-lite the driver that you do not want to keep and using the scroll bar on top click X for delete.


Only having 1 driver system solved my problems.


Hope this helps you as well.




I have the same problem. I can print but keeps getting the same error messages as above. Tried all solutions and nothing yet



If you continue to have difficulties with this error after reviewing the pages in this thread, I recommend you reach out to Canon support. You will need to register your Canon gear HERE to access additional support options.

We look forward to hearing from you.