Showing results for 
Show  only  | Search instead for 
Did you mean: 

Code 5,157,69 - MG5520


I have a PIXMA MG5520 printer.  The printer works, the copier works, but when I try to scan, I get a Code 5,157,69.  I have uninstalled and reinstalled the software, but nothing seems to work.  So my guess is that there is a setting which somehow got changed.  Please help.



I was getting the same error and tried un-install / re-install, which didn't work.  Then I turned of my work VPN to see if that was the issue and it was.  As soon as I disconnected the VPN it worked again, so the first couple of times I used the scanner I must not have been on my company's VPN.  Hope that helps!

View solution in original post



I have a similar problem with my Canon MG7500 which won't scan via network, giving me the same error code. I am using Windows 7 and the scanner did work before, but since we moved to a new house the IJ Scan Utility stopped working. I have tried everything described in this thread and scanning via MS Paint does work, as does printing. I don't see any option to scan everything into one pdf file with MS Paint. I'd really appreciate your help with this issue!

Thanks in advance!




I have the same problem here, Windows 7 x64, MX456 (FW 1.040), latest driver from 16-Oct-2013


o Scanner didn't work in Wlan mode, even after a fresh windows 7 install

o The scanner selector see the scanner and is selected

o FYI the scanner TCP port 8612 is closed, via nmap -P0 -p 8612 <ip>


MS paint scanner trick didn't work for me,



WORKAROUND : Until I did => Control Panel => Devices and Printers => Add devices => After a short scan, Select : "Multi devices, printer, scanner ..."


MS paint trick works after that 🙂



Sound like a firmware/driver bug


Canon QA/support, please, you should test this product to see the issues (at least this one)









PS: If the issue still exist on the MX450 series in 6 months, that's someone didn't do his job at your place 😕

It's not sarcastic it's realist !


After trying your workaround, I tried running the Canon scan again and it worked!

I am able to scan from Paint, but it doesn't solve the problem of trying to scan multi-page documents. I would like to have the functionality that I had before with this device. Please advise. 


I am using Windows XP and have had no issues with this until now.



Additional troubleshooting will have to be done to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

6 years later after this reply was shared and a few Windows OS's later, this tip still works in Windows 8. Not sure what precipitated for this to happen, but we need more of these forward-thinking programming efforts on the root level of all devices such as this effort, going forward. Thank you, @Ramona. ❤️

I have the scanner selector running and still I'm getting this error message.


I have recently switched my MG7550 printer/scanner from a LAN connection to a USB connection directly into my PC.  Now I can't scan using Canon sofware even though I can print.  I get this error code.  Grateful for any suggestions.


I have the same problems using Windows 10. Can't scan. The trick with paint did not work. Please help.




I got the same message, same scanner issue over Wifi with an MG5550.


I eventually solved the issue and got the scanner working over Wifi by installing all the software from scratch WITH the XPS optionnal driver. The XPS driver works for me for the scanner and not the standard one.


Best regards.