cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MX920 Printer not responding

jl487printer
Apprentice

The printer was installed and I printed fine the first day.  A few days later, the printer in not responding.
I tried reinstalling the driver; the printer is connected to my network.  Any support on this would be helpful. 

59 REPLIES 59

Urggghhhhh THAT I didn't need to hear , 2+ years ? This is the point where I use expletives ...

I tried the cleaning of the reflective strips and while they're probably quite clean now , it did nothing .  I know it's not mcafee as I said . I've used mcafee with this printer and the only thing that's changed there is I renewed my subscription . I've also basically surgically invaded mcafee and any possible connection to the printer is not impeding. 

I have since I bought this printer < a year ago changed routers . I use my cable company's router now  I did attempt to use an extender, and to mnimize any possiblity that it it was an issue ,I stopped using it and rechecked the settings of everything again . As I said in my reply to the cleaning of the strips post , all the I P and other network B S are normal . The most frustrating thing is that I just used the printer earlier this week and there was no issue . I live between two states and I need to use this printer here in NYC to accomplish minor business needs. The epson I have in AZ was temperamental to a degree but nothing like this. This printer has been used < than 10 X since its purchase so this , as I said , is ridunculous...

im going to try some of these other "fixes" that begin with "go to settings" that I haven't tried yet . 

Again, all the people who post possible solutions are really great, especially if it works for someone . I appreciate your help .

Just FYI, I'm running Windows 10 but have been since it came out and it's the only OS that I've used with this printer *

I should also mention that it's not the router.  About a year after this "printer not responding" issue first began, I replaced our router.  No surprise, the printer has behaved just as miserably with the new dual band router as it did with the old router. 

 

Essentially, the printer refuses to  communicate with any other device until it has been power cycled.  If the problem did not lie solely within the printer itself, then powering the printer off then back on would most likely have no impact. 

 

 

 

  

 

 

Hello.

 

Additional troubleshooting will have to be done to narrow down the causes of your issues. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

keithk,

    Thanks for the info saved me from buying a new printer when it wasn't needed. THANKS!! 

Hello,

I have the same problem as a lot of other people. Using wireles printing and running windows 8. When printing after some time I get several messages "Printer requires your attention go to the desktop to deal with it". But everything OK. I still can print a few times. But then "your printer is not responding". Everything OK, but no printing possible. Only solution OF/ON. It is a brand new printer.

Hello Sonja,

The issue that you are having sounds like a communication issue. Confirm that your printer and network are communicating properly:

  1. Press the Menu button.
  2.  

     

  3. Select Setup, then press the OK button.

  4.  

     

  5.  

    Select  Device settings, then press the OK button.

 

 

  1. Use the UPDOWN button to select LAN settings, then press the OK button.

 



 

Once the LAN Details page prints out, verify that the signal strength is over 50%.  If it is above 50%, try reinstalling the printer driver from HERE.

  1.  

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I have signal strength of 100%. downloaded the drivers but still not commicating with the printer. I had to go to the USB wired to be able to print. What is the poinnt of having a wireless printer if it will not print wirelessly. This printer is only 2 years old. I should not be having these problems.

Having dealt with the "printer not responding" issue since March of 2014, we were next beset with error 1403, "The type of print head is incorrect. Install the correct print head" and a nonfunctioning printer. 

 

I've finally done what I should have done a long time ago... I've replaced the printer.  What a relief!  What a joy! 

I'm having the same problem with my PC Windows 7. I'm also connected by WIFI. I've checked that connnection and it's fine. I can also copy, so the printer is working. But any time I go to pritn, I get "printer not responding." Thanks 

Avatar
click here to view the gallery
Announcements