cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MX920 Printer not responding

jl487printer
Apprentice

The printer was installed and I printed fine the first day.  A few days later, the printer in not responding.
I tried reinstalling the driver; the printer is connected to my network.  Any support on this would be helpful. 

59 REPLIES 59

I just got this stupid thing.  I can't believe I have to do that every time it decides not to print.  My previous Canon printer worked all of the time.  I don't get it....

It's very frustrating.  I liked my previous Canon much better than this one, which can be a real PITA. 

 

I have found that I can usually just power the printer off, let it set for a minute, power it back on, and then it works.  It's really a nuisance. 

I have a new mx722 and have the same issue. I have to power cycle it to get it to print. Annoying to say the least.

Win 7, connected through my wireless network.

It was my Netgear router.

Just got a new Netgear router and now can't print - what was the problem?

Keithk -- Thank you for the help! It worked like a charm. I actually used dry QTips because the wet ones just smeared it around.

 


@keithk wrote:

Hello - Amazingly, I actually got efficient assistance from the Canon tech rep I spoke to!  Directly, here is the fix.  Power down the printer and disconnect power.  Open up the printer as if you were replacing ink cartridges.  The cartridges will be on the far right, so you can clearly look into the back of the cavity.  Using a flashlight, you will notice what appears to be a long piece of plastic (less than a half-inch wide) stretching horizontally across the back of the cavity (it will reflect the light and be obvious.)  Using a cotton swab (ideally one with a long stem) moistened with either water or isopropyl alcohol, Gently clean as much of the length of the plastic as you can.  The swab end will be black with ink.  I gently repeated the procedure and let the plastic dry.  I powered up the printer, and problem solved!


 

Canon -- In what universe is this an acceptable fix?! Boooo, poor product design. I'm a long-time Canon fan, and will continue to be, but this leaves a bad taste in my mouth.

I would love to be able to try keithk's simple solution as it sounds like a miracle fix for those who have been able to implement it. However, I am not sure what strip of plastic needs to be cleaned. When I look into the back there is an upper strip of a translucent, brownish plastic material. This strip is completely clean. About an inch below it there is a black and gray strip that is smeared with ink. I am hesitant to clean this one thoroughly as in addition to ink, the swab lifts off something that looks like a type of lubricant i.e. vaseline. Can anyone who has gotten this fix to work please confirm which strip of plastic needs to be cleaned? And if it is the lower strip, is it necessary to reapply some type of lubricant to it after wiping off the ink?

I need to thank you from the bottom of my heart - I was ready for flinging my printer through the window!! I am now in love with it again - thank you for posting ❤️

i d k if you have the mx922 but i do. I have been having the issue with "printer not responding" and being in "error". I also called canon and a seemingly efficient woman walked me through various steps. When the problem was not resolved , she blamed Mcafee( it is not mcafee).

The reason I'm replying here is because a) I appreciate people who render assistance, so TY. and b) just to clarify, you stated a long 1/2" wide bar on the back behind the ink cartridges; further along in the post you mentioned plastic.Inside my machine there are 2 bars, one is silver and so obviosly reflects well. It also has 2 black lines that run through it. The only plastic bar is one that lies flat and runs across the back and is very obviously white(just a question of clarity).

I just cleaned both with a qtip and alcohol. The metal bar/strip was the one that had the most ink residue, the white one, not so much. Hopefully this will help since I am not that tech savvy and there was no issue before with this printer. It's barely been used . Al IP and other BSl configurations seem to match up so my process of drudging through elimination of causes continues. I hope your suggestion works for me too.

Thanks again!

I have dealt with this issue for 2+ years.  When it first started, the issue occurred sporadically, perhaps once every other month or so.  The problem has worsened over time until now it's just a given that when I'm ready to print a document, and it's been more than several hours since I've power cycled the printer, I know I'll have to power it off, then back on again, before it will "respond." 

 

This issue can't be blamed on McAfee, because I don't have McAfee installed on any of my computers.  It's not the computer's OS, because 2 are running Vista, 2 are running Windows 7, and 2 are running Windows 10.  Plus there are a couple of Android tablets and and smartphones and 1 Chromebook.  The network's WiFi signal is strong and there are no connectivity issues.   The problem lies solely with the printer.

 

 

Avatar
click here to view the gallery
Announcements