Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MX920 Printer not responding


The printer was installed and I printed fine the first day.  A few days later, the printer in not responding.
I tried reinstalling the driver; the printer is connected to my network.  Any support on this would be helpful. 



Hi, jl487printer!

So that the Community can help you better, we will need to know exactly which operating system is running on your computer, along with how your computer and your printer are connected to each other. That, and any other details you'd like to give will help the Community better understand your issue!

Thanks and have a great day!



Mac is runniing on OS X 10.9.1 

Both (Mac and Canon MX 922) are connected wirelessly to my home network.

Connecting MX 922 to the network works just fine.


I set up "Print from Email" which works when printing from iPad.


Hope this is enough info for you to provide some support.  

Hello jl487,


Did you reinstall the driver from the CD or the Website? If the CD was used, try installing the updated driver from HERE and let us know what happens.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I have the same problem as a lot of other people. Using wireles printing and running windows 8. When printing after some time 3 or 4 times I get the popup message "check your pinter". But everything OK. I still can print a few times. But then "your printer is not responging". Everything OK, but no printing possible. Only solution OF/ON.

Hello - Amazingly, I actually got efficient assistance from the Canon tech rep I spoke to!  Directly, here is the fix.  Power down the printer and disconnect power.  Open up the printer as if you were replacing ink cartridges.  The cartridges will be on the far right, so you can clearly look into the back of the cavity.  Using a flashlight, you will notice what appears to be a long piece of plastic (less than a half-inch wide) stretching horizontally across the back of the cavity (it will reflect the light and be obvious.)  Using a cotton swab (ideally one with a long stem) moistened with either water or isopropyl alcohol, Gently clean as much of the length of the plastic as you can.  The swab end will be black with ink.  I gently repeated the procedure and let the plastic dry.  I powered up the printer, and problem solved!

Thank you, keithk, for coming back and posting your solution. 


I received the "Printer not responding" message today when I tried to print a document.  The copy function worked just fine, but each time I tried to send a document from a computer to the printer, I received the dreaded "Printer not responding" message.  


I tried the solution you posted, used alcohol on a Q-Tip, gave the strip a little time to dry, and problem solved.  Documents are printing once again, and no more errors.  


I got excited when I saw your siple solution. Unfortunately thiss did not work for me. I am still getting the printer not responding message. I have uninstalled and reinstalled the drivers from the disc. updated from the website and followed every step of the troubleshooter twice. Still not working. About ready to toos this out a window. Everything works but prinnting from the computer whic was working until a few days ago.

Thanks Keith! My printer printed fine yesterday and then NOTHING today! I tried the solution you posted and WALA! It worked on the first try! Thanks SO much!


I was doing just fine these past weeks. My Canon 920 was sailing along as I printed 4x6 colored prints. Then yesterday it stopped with this support code c000

"Print error has occurred.

Follow the steps below.

1. Cancel printing, then turn the device off.

2. Turn the device on again.

If problem persists, see the manual and contact service."

I reinstalled the driver on my Mac Catalina 3x now. Still no luck. I have no jobs in the queue. I unplug my printer. Restart. Hoping. Fails and fails again. Help!

click here to view the gallery