Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MG2522 not being found on laptop



So I am running into an issue with my new printer, I can't seem to detect my new printer via USB like it should. I am currently using an Asus Windows 11 gaming computer though  im not sure if that matters or not. I have downloaded all additional drivers that Canon recommended but I cannot download the MP Drivers that I need so I can scan files from the printer to my computer. I have looked at how they connect the printer and even on Youtube before coming here. It is not damaged, and I have followed the directions on the computer that the download needs. 


I am just confused why it isn't detecting the USB port for the printer/scanner I have. 


Product Expert
Product Expert


If you try another usb port on the computer and it's still not detected, please try the following

1.  Open the Control Panel by holding the Windows key and pressing the letter R.


2.  In the Run window, type "control panel" (without quotation marks) and click OK.


3.  Click Devices and Printers.


4.  Click Add a Printer.


5.  In the new window that appears, click on your printer and then click Next.


A driver will be installed.  When this process has finished, click Finish.

If the scanner driver is still not installed, the security software on your computer may be interfering with the printer installing correctly. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


So I was able to get the printer to work, however, the scanner portion wont work because I cannot download the MP driver onto this laptop for some reason. I looked at my security software but It doesn't seem to be the issue because I tried turning it off and back on, I think ill have to keep trying different things to figure it out. I really appreciate this help. Do you have any other suggestions?


If the laptop is running off battery when you are trying to install the MP driver, then please connect the laptop to an outlet and try again. 

If the issue persists, I recommend reaching out to Canon support for real time support with this issue. You will need to register your Canon gear HERE to access additional support options.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.