Showing results for 
Show  only  | Search instead for 
Did you mean: 

problem with DPP after update to MacOS Mojave


I recently updated to MacOS Mojave and encountered a very strange problem in DPP4. I cannot throw images into the trash anymore. I did give the DPP4 application permission to control my computer in the privacy and security settings. I updated DPP to version 4.9.20, but it did not make a difference. All the other features seem to work. Has anybody any idea how to solve this peculiar problem in the software?


Hi John,

That works OK, but it is an extra step.  It is much easier to right click on the picture and move to trash.  That's the way it use to work on the latest version before mojave.  Thanks for the input

I wanted to see if it was a problem with the actual file. I had a problem once where something prevented me from moving a file to trash; I forget the solution, but it doesn't matter since thats not your problem.


I understand with the feeling about finger pointing, but I have DPP 4.9.20 and Mojave and don't have that problem (I just verified it). 


That must mean there is a third factor involved.


Maybe if you used an uninstall app and then reinstalled that would clean up something thats hanging around.


Helene above resolved her problem with a clean install of OS, so it would seem its not a DPP problem. What if you tried re-installing Mojave as an update (w/o cleaning disk)

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

FIle attributes and testing for read, write, execute are wide open to the world. Interestingly, renaming a file, works only, regardless permissions. I did notice Apple xattr (file meta attributes are the only thing that stands out). Since Apple has systematically changed OS "root" authority permissions with Catalina, some of which have also changed with Mojave as well. The updates literally have taken control of specific file folders where cached information resides ~/Library/Application Preferences/, to some extent controlled by Apple. The problem is "poor" architecture of the OS and file system hygiene. The Operating System is separate from App, and separate from User data as it should be. And Apple will tell the OS is 100% secure, but what about App, and User data? I can answer that for you it is a sandbox, previleges for access to entire your archive of photos is not for public consumption. 


Good Morning!!!


I Just tried to do the same and had no problems.

DPP 4.9.20

Mac OS 10.14.1


The first time asked a question about give permissions to DPP in Finder to make changes.



EOS Digital Rebel / EF 28-135mm f3.5 - 5.6 IS USM / EFS 15-55mm f3.5 - 5.6
EOS R6 / EOS R50 / RF 7 Art. 35mm f1.4 / RF 50mm f1.8 STM / RF 15-35mm f2.8 L / RF 24-70mm f2.8 L / RF 70-200mm f2.8 L

Just joined as I have discovered the SAME issue with my Canon 9000F. Canon tech support told me they are no longer supporting this scanner! Not happy.


However, by doing some serious googling, I have discovered an alternative to buying a new scanner (Canon doesn't even offer a flatbed which does photos, slides and negatives anymore -- something I need)!  While it costs a bit (US$99.95 after you trial it for the "professional" version needed for slides and negatives -- watermark appears on scans), try VUESCAN. You scan via their software, not the Canon driver.  I am now trialling it to see if it does what I need.  Not thrilled with the $100, but the alternative of buying a new scanner when this one works perfectly fine would be that much more.

I use Vuescan with a Minolta scanner. Driver ended with XP. Works fine now with W10. Haven't tried it with macOS.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Has anyone tried SilverFast 8.8? This seems to be another 3rd party company that will scan your photos and documents on several different scanners including the 9000F.  Trying their demo now also


I have the same problen called Canon they were no help - I can Delete on my desktop but NOT my MacbookPro which is my shooting computer. This really sucks - as a life long Canon owner and a Pro this is no way to treat us. When a client is looking at the images on set it would be nice to delete the 1st serveral files.  CANON Help how about it . We're not making this up . 

Peter Olson Philadelphia.


The answer is:

System Preferences / privacy / Full disc access

Click on the padlock and then add in DPP4 using the finder.

(This might not be enirely necessary but I think it helps!)




System Preferences / privacy / Automation

You'll see DPP4 and a tick box underneath 'Finder'

Tick the box and then click the padlock to save changes.


This should now work. 


Thanks to Canon tech support for getting most of the way there!

A few weeks ago in some trial and error sessions, I've found this solution too, but I did not find the time yet to exactly write down what I have changed. But I had adapted the system like you proposed. 

Problem solved.


Best regards, 


Koos Blokland

click here to view the gallery