cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Image Transfer Utility 2 not working... how do i fix this?

BERZERRK
Apprentice

This just started happening today..

 

I click to open the application and nothing happen, like it doesnt even try to pop up then close. I check task manager to see if its running in the background its not there. Ive uninstalled and reinstalled the app & its the same thing. Any help is grately appreciated!

12 REPLIES 12

Waddizzle
Legend
Legend

Which camera are you trying to use?  

 

What computer and operating system are you trying to use?

 

If you looking to use EOS Utlity 2, then I guess you have an older model camera and using USB.  Check your USB cable.  Make sure that you are using a USB data cable, and not one of those USB power cables.

--------------------------------------------------------
"The right mouse button is your friend."

i have a canon EOS M50 & im not trying to transfer through cable, i was trying through wifi

 

Also im on windows 10

Waddizzle
Legend
Legend
Use USB, because it is MUCH faster. The Wi-Fi is intended to work best with mobile devices.

Having built in Wi-Fi does not mean your camera is fully networkable. The cameras seem to use it as a longer range Bluetooth. Canon sells adapters that make cameras fully networkable.
--------------------------------------------------------
"The right mouse button is your friend."

I have the same issue with IMAGE TRANSFER UTILITY 2 (Canon SX70 HS). Last year, after some win10 Pro/64bit/ update my ITU software does not start anymore. Till that time everything was OK and transfer was done automatically bi WIFI. Tried uninstall and reinstall of software but no result. How can I solve this?

Adrian, same problem. Found a fix yet?

adrian_ciortea
Apprentice

sorry but NO!

BTW Canon support SUCKS! They're just sending you to different links but nobody checked the real problem! I'll move to another brand and I'll recommend all my friends using Canon to make the same move. I hope I'll find another dumb to sell my rig...

tperk100
Apprentice

Found my Fix

Control Panel (view Icons), Autoplay, scroll all the way down to devices , your cam, and tell sys  what to do when connected. Mine was set to do nothing, changed it to fiirst choice (Canon Cam Window). Works great now.

My Windows 10 machine does not show a "Canon Cam Window" as an option under Autoplay for the camera.  What is Canon Cam Window?

 

pjchris91
Apprentice

I have discovered that IT2 is not completely shutting down its processes when you close it.  If you have run it and need to use it again, use the Task Manager to shut down any Canon Image Transfer 2 tasks that are running.  Now, start IT2 and it should start up and allow you to proceed normally.  This is clearly a bug.

Avatar
click here to view the gallery
Announcements