Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS utility does NOTHING


I have a Canon t3i that I'm trying to get photos off.  Used to be easy with EOS utility.  Used to be able to just simply download photos, all nicely arranged in dated folders.  Now?  Run all over the internet looking for the necessary software (because, gosh, can't find it on the CANON website), install it all, start up EOS utility, and it does...NOTHING.  So at what point did Canon decide to just blow off T3i owners and not support this useful utility any more, and what did they replace it with that has equal functionality?  Expecting the answer "nothing".  



@hitman62 wrote:

I'm having the same problem with EOS Utility 3.7.0 that I use with my 5D Mk3 and my T6. It was working fine until 11/10/17 when I did a mandatory windows update. Since then I can't get EOS Utility 3.7.0 to load in anyway. I even tried the version supplied with the camera to no avail. IMO it has something to do with that update. My update history shows Windows 10 version 1709.


I've been scouring the web looking for others having this problem and havn't found a solution, now I'm having to LiveView shoot to shoot tethered  then use Lightroom to see the image after it's shot. No fun, please offer a solution asap.

I, too, had a massive Windows Update that seemed to adversely affect at least one application, but not EOSU.  My laptop needed to spend a couple of minutes downloading new drivers from somewhere and installing them.  I am using a Dell.


Check your startup options for when a camera is detected connected to the USB, too.  You may need to start the EOS Utility manually one time, in order to wake it up.  I have found this was needed on a couple of laptops since 2014.

"The right mouse button is your friend."

Ok finally had some time to figure it out with all the responders and it's working now. I did ll the usual uninstall restart then reinstall a few times, tried disableing then enableing the app in start up. After reading one of the post to go directly to C:\Program Files (x86)\Canon\EOS Utility\EU3\EOS Utility.exe I was getting the the error "EOS Connection app already running" I right clicked and choose "Troubleshoot Compatibility" and followed the prompts, I can now report ALL IS GOOD! Thanks for your help everybody.

I just did the right click and said worked on win 8   When I reconnected and clicked on EOS Utility2 it said that the clock on my pc and clock on camera different and did i want to fix  said yes and all good now   



Thanks for help - just wondering if the clock (daylight savings change) was the issue in the first place?!!  Anywho all good now 🙂


Canon EOS no longer auto dectecting?

It's not your cable or your camera. (I personally shoot a canon t4i)

This frustrated me a ton!!!!




The problem is the version of Windows 10 you have.  If you have version N, everytime Windows updates, you will find your camera (and many other usb devices like smartphones) are no longer detected.


This is a total pain in the arse, but every time Windows 10 does an update you need to download the media feature pack.


Here is the link:


I registered specifically for those who are having the same issue and spent hours sifting through the internet for a solution


Here is something to check. I had used another piece of software that changed drivers. I changed it back as instructed but it loaded the wrong driver back. For Windows 10 the driver is MTP USB Device. So if you go into Device Manager and find the camera listed as a Canon USB Camera, then that is your problem. Right click on it, select update driver, browse for driver, pick from a list, and then select the MTP USB Device. It should now be recognized as a Portable Device and by the name of the camera model. After that, the EOS Utility should load and allow you to use all the options again. 


Apparently, in 2021 this is STILL a problem. Smiley Mad

What's up, Canon? 

@NotHappy2 wrote:

Apparently, in 2021 this is STILL a problem. Smiley Mad

What's up, Canon? 

Not clear what the problem is.


I use EOSU with W10 and have no problems at all.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Can you give more info? Like:
- your operating system?
- your EOS utility version? (v1 or v2 or v3)
- how do you connect the camera to your computer? (via cable or wifi or something else)
Enter for a chance to win