cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS utility does NOTHING

lbb
Contributor

I have a Canon t3i that I'm trying to get photos off.  Used to be easy with EOS utility.  Used to be able to just simply download photos, all nicely arranged in dated folders.  Now?  Run all over the internet looking for the necessary software (because, gosh, can't find it on the CANON website), install it all, start up EOS utility, and it does...NOTHING.  So at what point did Canon decide to just blow off T3i owners and not support this useful utility any more, and what did they replace it with that has equal functionality?  Expecting the answer "nothing".  

 

17 REPLIES 17

Waddizzle
Legend
Legend

 

 

https://www.usa.canon.com/internet/portal/us/home/support/details/cameras/support-dslr/eos-rebel-t3i...

--------------------------------------------------------
"The right mouse button is your friend."

Amazingly, I managed to find that page, all by myself.  Those downloads are completely useless and do nothing.  

Have you tried a new cable?

TCampbell
Elite
Elite

What computer OS are you using?

 

Also, if the version you launched includes an application named simply "EOS Utility" (no other letters or numbers) then that's really the EOS Utility launcher.  It's supposed to detect the camera and then either launch "EOS Utility 2" or "EOS Utility 3".  I've noticed that my "launcher" does do anything when I connect a camera (it's as though it can't see the camera).  But if manually launch "EOS Utility 2" or "EOS Utility 3" (bypassing the "launcher") then they work fine.

 

BTW, I generally never use the USB cable to transfer images.  It's usually faster to just insert the SD card into a card reader (and a lot of computers have a built-in SD card reader.)

 

Tim Campbell
5D III, 5D IV, 60Da

hitman62
Apprentice

I'm having the same problem with EOS Utility 3.7.0 that I use with my 5D Mk3 and my T6. It was working fine until 11/10/17 when I did a mandatory windows update. Since then I can't get EOS Utility 3.7.0 to load in anyway. I even tried the version supplied with the camera to no avail. IMO it has something to do with that update. My update history shows Windows 10 version 1709.

 

I've been scouring the web looking for others having this problem and havn't found a solution, now I'm having to LiveView shoot to shoot tethered  then use Lightroom to see the image after it's shot. No fun, please offer a solution asap.

Unfortunately I am not an expert on Windows 10 -- I primarily use macs.

 

However... a few things you might check on.

 

1)  The cameras don't really use "drivers" anymore.  Is there a way you can go into Windows list of detected hardware devices connected via USB and see if the Windows operating system can even detect the device?

 

2)  Is there any photo software running on Windows?  Typically once any piece of software recognizes and grabs a connected hardware device, no other software will be able to access that device.  

 

In other words, I'm wondering if something else in Windows "sees" the camera and grabs it... making the camera unavailable to the EOS Utility.

 

Hopefully someone more familiar with Windows 10 may be offer you some specific steps to check.

 

 

Tim Campbell
5D III, 5D IV, 60Da

Windows detects it fine, and I have no problem copying images.  I just miss the convenience of the EOS utility, which would download them into folders based on date.  


@lbb wrote:

Windows detects it fine, and I have no problem copying images.  I just miss the convenience of the EOS utility, which would download them into folders based on date.  


Have you tried starting the EOS Utility manually?

--------------------------------------------------------
"The right mouse button is your friend."

Sorry to hear of your issues guys.  I'm running latest non insider build of W10, Fall Creators 1709 (16299.64).  Zero issues here.  In fact I just used the EOS utility to upgrade the FW on my body.  My EOS is latest available 3.7.0, DPP on this box is 4.6.x.  4.7.x everywhere else.

 

Testing with a different cables as others mentioned is a good first step.

 

If that fails:

 

If the EOS utility is running in your System Tray, right-click and quit.

 

Now open Control Panel > Programs and Features > then select the EOS Utility 3 in your programs list

 

Press the uninstall/change button at the top of the list.  Perform a repair install

 

I've not needed to do this myself, and not every sofware includes a repair option..  only Uninstall/Remove

 

If thats the case, remove the software and restart your PC.

 

Download a fresh copy of EOS Utility from Canon's website (its easy to find) 

 

https://www.usa.canon.com/internet/portal/us/home/support?tab=drivers

 

Enter your camera Model, press Go.  Then select Drivers and Downloads button on your camera's body page.  EOS 3.7.0 is there.  Install, restart and test again. 

 

Its possible that a 3rd party AV software might interfere with camera connectivity.  If you are using Windows Defender, that won't cause a problem.

 

Visit this link for a list of supported models...  Man Happy

 

https://www.usa.canon.com/internet/portal/us/home/support/self-help-center/eos-utility

 

 

 

 

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements