Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Web Registration Tool Failing


I have entered valid login credentials below, and all it does is launch my browser.  It never lets me past the login screen.  

I have the latest software and firmware.




How long has it been since you last logged in?  I thought the Gateway was shut down two years ago. 

"The right mouse button is your friend."


This camera is brand new... I'm following the instructions in their own software.

The camera might be brand new, but the model is a few years old.  Follow the instructions at the link and be sure to download the latest copy of the User Manual. 

"The right mouse button is your friend."


Not sure how that helps. sends me right back to where I started - it wants me to usue the web service registration tool to initialize the connection, and that's a fatal loop.  

Contact Canon Support.

"The right mouse button is your friend."

Product Expert
Product Expert

Hi FNBrown,

When you first set up the connection through the EOS Utility it will have an Image Gateway login prompt. Once the connection is established it will be done through the current cloud service.

There are a few things to check when the login isn't completing. The first is to make sure you have the current version of the EOS Utility installed. The current version can be downloaded HERE. Once you are on the web page click on the gray Drivers and Downloads button and the current version is EOS Utility 3.15.0. Once the EOS Utility is updated check to see if the same thing is happening.

If the issue continues the next thing to double check is that you have an account set up HERE. If you do not currently have an account on that page click on the gray person icon and you will have the option to create an account. Sometimes if you do not have a Canon account set up there it can prevent the log in from going through.

If that doesn't resolve the issue then we would recommend installing EOS Utility on a different computer and try to set up the connection there. Sometimes operating system or security software settings can cause issues like this. If the log in goes through on a second computer that indicates settings on the first computer were causing the issue. In that case we would recommend contacting the maker of your operating system and security software to trouble shoot their settings.


I'm having the same problem with my rebel T6 (1300D), I've tried:
Different computers, different operating systems, setting up firewall exception, different networks, different versions of EOS utility, contacted the Canon service center to check there was something wrong with my account setup.

Still can't find a solution

Have you tried the suggestions listed above from Hazel_T, Canon Product Expert?

"The right mouse button is your friend."

Sadly yes, all of them besides getting in touch with Microsoft.

Thank you anyway

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.