Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS VR utility out of memory error on Mac M1 MAX


I recently acquired an RF 5.2mm Dual Fisheye lens and have been practicing with it. I am working with an EOS R5 at firmware 1.8.1 ans a MacBook Pro M1 MAX with 32G of memory, running the latest Mac OS.

When exporting clips from either the EOS VR Utility or the Premiere plug-in, the computer throws a critical out of memory error and frequently hangs. I have performed several experiments with various clips and various export CODEC settings, and in all cases while monitoring resource usage on the computer, the process starts in a few seconds and progresses along with reasonable CPU and GPU loads, but if the clip is longer than approximately a minute suddenly the memory pressure increases to red and my swap space, which is normally unutilized, is rapidly consumed until the OS gives up. If I cancel teh export whule the swap file is being consumed the memory pressure returns to normal, but if I try to export another clip the memory issue reappears immediately.

I have not purchased a license for the software yet, as I would like ot know that it works before I do so...

I have had similar issues either running in CPU only mode or in MAC M1 mode.

Any suggestions would be much appreciated. I am happy to provide screen caps or logs if necesssary to help solve this issue.






Product Expert
Product Expert

Hello lassini,

To enable 30fps playback and rendering of 8K/4K MP4 and *K CRM (RAW) files shot with the EOS R5, you would need to have a system that meets all of the following configurations. Even if the recommended environment is met, it may not be possible to play smoothly.

- Intel Xeon W 2.5GHz 14core or greater
- 32GB or more
- Radeon Pro Vega 64
- Apple M1 Ultra chip 20-core CPU or faster
- Apple M1 Ultra chip 64-core GPU or faster
- 64 GB or more




thanks for teh reply. I understand that smooth playback of 8K video is resource intensive, but that is not my issue. Nowhere it says that the VR utility needs an M1 ULTRA chip and 64G of memory to do its job, which is to export an equirectangular side by side video from the dual fisheye capture! This is not a real time process, but rather about 1/10 of real time on my machine.

If the export is less than one minute the job concludes in about 10 minutes and all is well ! 🙂

If teh job exceeds one minute, at some random point teh app's memory consumption, which is constant up to then at about 4 GB, suddently skyrockets, and soon my OS is completely unable to allocate any heap and it crashes hard.

here are a couple of screen captures:

The firsat two represent the start and successful conclusion of a 59 sec export job. Tjhe rest show the start, mid phase and memory runaway of a 1:40 job - same source file. The app memory consumption is near constant for teh first minute of video at around 4 GB, then it explodes. This does not seem like an issue due to not having the absolute greatest processor that apple makes...

Let me know if I can provide you more info!





Start of 59 sec jobStart of 59 sec jobsuccessful 59 sec jobsuccessful 59 sec jobStart of 1:40 jobStart of 1:40 job1:40 job before memory runaway1:40 job before memory runawayMemory runaway starts at around 60% doneMemory runaway starts at around 60% doneJob canceled before it took my machine downJob canceled before it took my machine down


also note that the thread that explode is the VTDecoderXPCService, which is not immediately obvious to me. Is this one of the threads spawned by the EOS VR Utility? It does not appear in my Activity Monitor when the VR Utility is not running. Also, it does not seem to release its memory and resume function unless I quit the utility and re-start it.

Oh, and sorry for the spelling in the previous post, i am an horrible typist...




Greetings lassini,

Thank you for providing us with the additional information along with the screenshots. It does appear that memory usage is being capped out on your system when using the application. The OS would then need to use virtual memory from the hard drive to assist when there is not enough physical memory available.

In case you're using an external hard drive for exporting then let's test to see if exporting to an internal hard drive will improve performance. Check to see if you're able to increase the virtual memory on your computer as well and please reach out to Apple for assistance with further assistance on this task.

We have not received reports of other customers experiencing this issue and you may test to see if exporting functions well when tested on a different computer.

Good Morning Natalya

Thanks for the suggestion. I just tried running the process on the same file from the internal SSD of my Mac, with similar results. One more observation is that during the initial part of the transcoding process the VTDecoderXPCService task runs with about 6 to 8 threads (it starts up at 3 threads when idle), and the process moves along well  as long as the thread count remains bounded. When the excessive memory consumption occurs the thread count for the VTDecoderXPCService starts rising very rapidly. Something in the logic of this process causes it to start spawning many threads, the count reaching well in excess of 100 before I shut it down to avoid hanging my system.

This is not normal behavior for a well crafted process. I am sure it is being triggered by something in my system but it seem to indicate that some error condition is not properly handled by this process. By the way, this happens also when I run the VR utility in CPU mode, not in accelerated MAC M1 Max mode.

I would be grateful if you were to forward my issue to one of your software developers. I appreciate that I am the first to report it, but it does not imply that should be dismissed... I will try this evening to run the VR utility on a different laptop (a brand new 2023 Macbook Pro with an M2 Pro chip) and will let you know if the results are any different.



Hello Natalya,

I just replicated the same problem on a brand new MACbook Pro with an M2 Pro chip and 16 Gb of memory. Brand new computer, purchased yesterday. Brand new VR utility installation downloaded 30 minutes ago. same behavior.

This is becoming concerning to me - how is it possible that this happens on 2 separate computers? It does seem to implicate an issue with the VR utility itself. I will try to capture another file with my camera when I get a chance, but I can open the camera MP4 file just fine and play it in its fisheye form either with quicktime or in Adobe Premiere with no error, so I doubt the source file is a problem.

Best Regards,



Hi lassini,

I have submitted a request to have our engineering team look into your issue. They are not a customer facing team, so they will not be following up with you directly. Once I get an update from them I will follow-up with you. At this time there is not an estimate for when I will get a response from them.

Hello Hazel,

Thank you for doing so! I look forward to hear back from them and you!



While I’m fairly certain the software could be better written, I do wonder if your computer’s resources are too constrained. Especially for a 16 GB one.

Remember that on Apple Silicon Macs, main and graphics memory are shared. So 16 GB really isn’t that much.  An Intel Mac with 16 GB main memory and 8 GB graphics card would have a higher amount of system resources.

While Apple’s claim is better memory usage efficiency, it’s not a replacement for larger capacity resources.

I do not like what Apple has done with the Apple Silicon Macs. Especially shipping ones with only 8 GB.

I currently use an iMac Pro with 128 GB RAM and a 64 GB GPU. So 192 GB total resources. Even if Apple is twice as efficient with RAM, an equivalent system (doing very simple math here) would be 96 GB.  There’s no way I can move to Mac with less resources than that. 

Virtual memory should also be avoided. Perhaps for small usages here and there. But if virtual memory is going to be leveraged for say 8 GB or more, performance will take a huge hit.


EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x