Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility - not launching?


For no apparent reason EOSU appears to have stopped working, somewhat. The main application does not load. I am using a D70 with EOSU on Win 7. I am attempting to connect wirelessly, this worked fairly well before.

I tried using the updated EOSU via Canon's website, but to no avail. Before the update, I sussesfully paired the devices wirelessly, but as Utility would not load after clicking the icon on desktop, no error messaged. The camera's wifi display seems ok (no blinking) - so I opted for the update. After this, when I click on the EOS UTility, it just says 'application already running.'

I am now at wits end having tried everything I could think of, please help!


I found out what was causing the problem on my computer.  It was AVG AntivirusEOS Utility stopped working on another computer and no I thought that was very peculiar.  I started looking harder at my configurations and starting turning things off. Sure enough it was AVG antivirus. As soon as I disabled it the EOS utility started working. They must have had a recent update that cause the problems because it was working before. No errors in AVG so I am going to have some choice words with them. It is unacceptable to disable a program and not display any notification that you are doing it. I have spent a considerable amount of time troubleshooting this.

View solution in original post


Hi Guys,


I've rung Canon support as was having the same problem with EOS Utility. They advised I remove all canon software from my PC, then disable AVG while I re-installed the Canon software. I can confirm this has worked! Smiley Happy



View solution in original post


Hi sparkycpg,

thank you so much, that was my problem! I disabled AVG and EOSU started!

Now I will think what to do. Thank you so much!

I also wanted to say that I wasn't able to get it to work again by just disabling the antivirus - I had to uninstall the whole program. When it still wouldn't work, I went through a few more threads on this and found the DPP sometimes needs to be installed (for whatever reason). After installing that, and uninstalling the antivirus (AVG), I was able to get it working again. Thanks to everyone for replying in this thread. I never would have figured it out otherwise.


If you have AVG you need to except all versions of EOSU.  They will be in seperate folders.  EOSU, EOSU2 and/or EOSU3.

Excepting one in AVG will not do the trick.

EOS 1DX and 1D Mk IV and less lenses then before!

Thank you, sparkycpg! I was really stuck on this one Smiley Happy


I do use AVG, and this turned out to be the guilty party, responsible for EOSU (all versions?) not properly launching/initializing..


I created exceptions for all EOSU versions, including all namesakes in the various subfolders (EOSLauncher, EOSU, EOSU2) in AVG -> Options -> Advanced Settings -> Exceptions - and EOSU launched/worked fine after that. No need to uninstall versions and whatnot.


Your considerable amount of time troubleshooting this has been extremely well spent, in my opinion! Am sure other visitors here may agree..

Thanks.  I created exceptions for all three programs and it is working great for me as well.  You might all want to know I have reported this to AVG, they have acknowledged it and are in the process if fixing it.  They said it should be fixed in their next update.

Thanks a lot for posting this.

I discovered that EOS Utility stopped working while I was away for 8 weeks photography. A major PAIN!

I only found your post after spending hours rebooting, re-installing Canon software, cleaning the registry, etc.


Did you find out how to prevent AVG from blocking EOSU, without having to disable AVG?



OK.. reading the other entries, I fixed it in AVG.


To make things a bit clearer do this:

Options>Advanced Settings>Update>Exceptions


Then "Add exception", Select exception type = "Application or file"


Then choose the .exe files for the Canon utilities (one at a time). The only box that needs to be checked is"Identity Protection" . Leave the others so scanning will still take place.


Hit OK.



Yes that is the proper way to do.  Mine has been working fine after I did this.  I did report it to AVG and there were suppose to fix it.  I don't know if they ever did.  I have not removed the exception to try it.

I have the same problem but do not have any AVG software loaded,



Thanks for the info. I was going to try a reinstall of AVG today so I'll try that.
click here to view the gallery