Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility - not launching?


For no apparent reason EOSU appears to have stopped working, somewhat. The main application does not load. I am using a D70 with EOSU on Win 7. I am attempting to connect wirelessly, this worked fairly well before.

I tried using the updated EOSU via Canon's website, but to no avail. Before the update, I sussesfully paired the devices wirelessly, but as Utility would not load after clicking the icon on desktop, no error messaged. The camera's wifi display seems ok (no blinking) - so I opted for the update. After this, when I click on the EOS UTility, it just says 'application already running.'

I am now at wits end having tried everything I could think of, please help!


I found out what was causing the problem on my computer.  It was AVG AntivirusEOS Utility stopped working on another computer and no I thought that was very peculiar.  I started looking harder at my configurations and starting turning things off. Sure enough it was AVG antivirus. As soon as I disabled it the EOS utility started working. They must have had a recent update that cause the problems because it was working before. No errors in AVG so I am going to have some choice words with them. It is unacceptable to disable a program and not display any notification that you are doing it. I have spent a considerable amount of time troubleshooting this.

View solution in original post


Hi Guys,


I've rung Canon support as was having the same problem with EOS Utility. They advised I remove all canon software from my PC, then disable AVG while I re-installed the Canon software. I can confirm this has worked! Smiley Happy



View solution in original post



Eos Utility (euw3.12.10-installer)
Does Not launch Eos Utility 3
when i connect my 6D or 80D windows is reporting the connection .
But Eos Utility does not respond in any way.

W10  V1909
Troubles startet after the w10 update or EU update, I can't tell.

I don't have AVG so don't bother mentioning.

PS what the flying FFFF is the networksettings tool.
Why do i keep on getting more and more bloatware?