Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility Not Working with MacOS Sierra


I am using a beta version of the new MacOS Sierra. In the early stages of the beta, the EOS Utility worked fine but in the past 2 releases, it has failed.


I am using a Canon EOS 700D and v2.14 ( of the utility. I aslo use an iMac 2009.


I have filed a bug report with Apple on this one, but there has been no action on their part yet to sort the issue. In any case, I suspect it may be left to Canon to update their software in line with the OS release.


Just wondered if anyone else had experienced the problem and if Canon were aware of it?


Well, I eventually found a Canon contact point for a software related issue. This is their response:


In response to your enquiry regarding software for your EOS 700D, we regret to inform you that the software for this operating system have not currently been developed.

Canon are due to be working on the development of software updates when the operating system has been officially released and will be available as soon as possible. Unfortunately we do not have a release date.

We therefore advise to consult our download centre, as they will be available to download and install from here, when released. Please find the link to this section below.


So, there we go!

View solution in original post

I honestly can't believe you guys.


I had ignored the last post at the top of this page as it was a waste of time responding. Firstly, it was recommended that I file a Bug Report to Apple. I had already reported in the initial post that I had done that.


I also stated that I am part of the Appleseed programme with a 2 way communicatrion system in place WITH APPLE ENGINEERS to feed back on their seeds. I am not using the public release of the Beta.


I stated that Apple will take no responsibility for 3rd party software which you disagreed with claiming it was Apple's responsibility. My response from Canon aknowledges this.


As for buying Canon's newest product and making sure that software is compatible by investing in a Window's machine? I hope that was a joke!


The software worked for over a year with the Mac OS -through various updates, seeds, betas, whatever! It has only now become unusable. I run more than one partition on this machine and if I need to, I can dive back into the previous version of the OS loaded on another partition. That is inconvenient, but it is an option. Cameras, Mac OS, Photoshop, etc, etc. They have gone together for years and are unlikely to be abandoned by the many photographers now.


I am sorry that I did join this forum. I never expected it to be populated by trolls and fanatics.


Thank you for your help. I have my solution. Subscription to the topic closed!

View solution in original post


@Miamic70 wrote:

Excellent post.


The various contacts with Canon show and reinforces just how clueless and out of touch this company actually is. I am shocked that one of their "solutions" is to suggest a 3rd party EyeFi card.  Makes me mad an feel stupid for supporting Canon since 35mm SLRs  and owning my current  EOS DSLR kits. I really think the time to move away from Canon is drawing near, they just don't seem to "get it" as a matter of corporate culture. 

Canon software works great with MS Windows.  It works with Apple OS, too, from what my sons tell me, even wirelessly. 


Personally, I think admonising the company because a legacy product never had built-in Wi-Fi is pretty dubious.  As far as EyeFi cards go, I have yet to see an EOS camera that supports EyeFi.  The instruction manuals warn users that Canon does not support their use ... ... probably because they are made by someone else.


Finally, you blame Canon for a 3rd party product with alleged problems working with some Canon gear, EyeFi cards.  Yet, at the same time, you still blame Canon for being a 3rd party product with alleged problems using Apple's OS.  Well, which is it?  Who is to blame when a 3rd party product has alleged compatibility issues with a manufacturer's gear?  You have blamed both, and in both cases it has been Canon. 


Good luck.

"The right mouse button is your friend."

Agreed. Canon does seem out of touch. On the side, I wish all the contributors to this thread would expend as much effort in prodding Canon to come up with a solution as they do trying to obfuscate the points of other contributors. 

Funny, several of my responses have been deleted. 

Maybe social media is goin to be a more appropriate place for me to seek answers since obviously this "support" forum lacks support and is full of Canon cronies. 

@Miamic70 wrote:

Funny, several of my responses have been deleted. 

Maybe social media is goin to be a more appropriate place for me to seek answers since obviously this "support" forum lacks support and is full of Canon cronies. 

This is not a "support" forum.

"The right mouse button is your friend."

Deleted my comment again?

So I will ask it gain. Then what is this community for if not support?




I'm confused as well. Perhaps our esteemed contributor would enlighten us as to where to obtain support?


Canon 5DMk3, Canon 5DMk2, Canon 500D

Canon 70-200mm F2.8, Canon 24-70 F2.8, Canon 14mm F2.8, Canon 1.4X Multiplier

Canon TS-E 24mm

Epson R3000, 4880

Hasselblad 503 CXi

Zeiss 60mm F3.5, Zeiss 150mm F4, Zeiss 250mm F5.6

Adobe Photoshop with NIK extensions, Adobe Lightroom, Photomatix HDR

Platinum/Palladium Printer

Over a month now since first post and Canon has yet to resolve the issues!

@Miamic70 wrote:

Deleted my comment again?

So I will ask it gain. Then what is this community for if not support?



This is a user forum.  While the forum is supported by Canon, it is for Canon enthusiasts.  Most every response that I have ever seen from a Canon moderator is a boiler plate response.  They will tell you if this a time critical issue to contact their support team.


Meanwhile, the folks around here are really just a bunch of geeks with Canon crystal balls, hoping they can help someone.

"The right mouse button is your friend."


This is unbelievable! I rely on the Canon Utility software and having updated to MacOS Sierra as always advised I now find I'm unable to download my images using the Canon Utility software!!


Shhhh...not too loud. In case you haven't seen, them's fightin werds. I have the same issues tho. My workaround is to download to Windoze, upload to a thumb drive, then download again on the mac. I would network the files, but the Sierra upgrade killed that connection so it's down til I can get around to fixing it. Wonderful, wonderful.