Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP4 version 4.9.20 Hangs Frequently Becomes Unusable


I updated to DPP version 4.9.20 on a Windows 10 PC with 32 GB Ram and found that after several minutes of use DPP would pause or hang for a couple of seconds and the Windows spinning circle warning would display. This pausing would happen repeatedly every couple of seconds making DPP almost unusable. The Windows Resource Monitor showed that the amount of memory under Working Set increases from around 977,000 KB to around1,500,000 KB for DPP4 as DPP goes from no problem to repeated pausing. I uninstalled DPP 4.9.20, rebooted and reinstalled the old version DPP4, 4.6.30 but still had the same problem with the constant pausing and increasing use of memory even though this version worked without a problem on this computer. Canon's technical support had not heard of the problem and was of no help. Has anyone else expericenced this problem and come up with a solution?


I think I have really solved the problem with Canon Digital Photo Professional 4 giving the spinning wheel wait symbol and pausing constantly. I did a drive cleanup on the C: drive and on the drive I have my RAW files on to get rid of all temporary files, etc. I was thinking maybe when I installed the updated DPP 4 that it may not have cleaned up all of its temporary files, or a temporary file got corrupted etc. So tonight I have been able to work with DPP for 4 hours without any spinning wheel wait symbols and pauses. 

View solution in original post


Changing the startupfolder doesn't work. Actually changing the startup folder requires that i push "browse" which also starts this spinning wheel thing. 

I am a bit sceptical to install software to monitor my file system activities as BruceB suggests. Looking at the resource monitor and the task manager, it seems it is DPP causing the problem all the way. It doesnt seem to me that anything in particular is stored when it starts doing this. 

No install, it is a free standing executable.

@yhafting wrote:

Changing the startupfolder doesn't work. Actually changing the startup folder requires that i push "browse" which also starts this spinning wheel thing. 

The wheel is spinning because it is looking for image files, and finding them.  It is building previews of the images it finds.  Change the startup folder in Windows Media Player and Digital Photo Professional, both of them.  


You can stop the behavior by not feeding it.  Set the folder to a folder without any media in it.  I created an empty folder in my root directory on my “C:” drive.  Also do not store hundreds of image files in a single folder.

"The right mouse button is your friend."

What good is this program if i can't use it with folders with pictures?

It did actually work without spinning wheels using the last displayed folder until i do some action that triggers the perpetual reloading.


It may well be that it is building some kind of preview data, only that it never finishes (it does eat up all available RAM at some point if i allow it to continue. - I had it going while eating dinner and doing some other stuff and it was closing on 12 GB.  

What i do not get is why the media player should have anything to do with this? 

It seems unlikely that i can use DPP and avoid "feeding" this mechanism, when simply using a drop down menu (without selecting any folder) will trigger this odd behavior. 

On my computer DPP was almost unusable, but this has changed after moving all my photos from the main drive to an external (previously empty) HDD

"On my computer DPP was almost unusable, but this has changed after moving all my photos from the main drive to an external (previously empty) HDD"

I wish that would have helped. My photos are all on a separate disk, and have been so all the time. (Fast SSD for programs, large HDD for photos and such).  

When you go into the tools/preferences/general settings menu in DPP, what is it showing in the temporary files area?  Any chance it has filled up this storage spot and isn't releasing space?


When it is hanging up, use ctrl + alt + del to go into task manager and see what it shows for disk loading and what processes are taking up the majority of the resources.  Win 10 search indexer is a well known problem child and when it gets triggered by user behavior or other programs it will hog the disk resources as it tries to build its search index. I kill search indexer but it is often brought back to life by the constant Win 10 updates forcing me to remove this bloatware once again. The Win 10 Malware manager is another huge consumer of disk access resources and like Win 10 updates it often goes into heavy maintenance mode at the most inopportune time forcing your application to fight with it for resources.


Also, the way task manager displays resource utilization you can have one disk in a multiple drive system running at 100% read/write capacity while task manager displays a much lower percentage because it is displaying overall system utilization instead of just one individual drive which may be maxed out at that point causing it to become the bottleneck.  


There is a free system monitor program Hwinfo64 which will display a tremendous amount of system data including a lot of information on your drives and controllers including drive health so you might take a look at those to see if anything odd is going on. is very well behaved on my computer.  I do have it set to start on a blank directory to avoid the time it takes to load files from the last directory used but even with somewhat over 1,000 files in an individual directory it is under 15 seconds to load the preview files from the long-term storage location on a mechanical drive and even less for current files which I transfer from the camera to a SSD for processing.


Good luck getting it figured out.  I have had issues with earlier versions of DPP and Win 10 itself is a multi-faceted disaster that has taken far too much of my time but I am very happy with the current version of DPP.



EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

Thanks for the tip Rodger. 

I have been monitoring everything from the task manager (i'm used to that) for the whole time. 

This time however i took the pain of ending one task at a time until i found
"NVidia Container", which until now had gone completely under the radar. 

The paradox is, when i use "end task" on this, it seems nothing happens, however the wheel stopped, and DPP seems to work just fine, that is i get exactly one brief wheel  when i do the things that earlier would trigger this to go on and on perpetual. 

You can add to this that this would have to be done every time i start DPP, then it would run fine for a few minutes. However we are not quite finished yet:

So below the process in the task manager, there was an expandable instance of the same name (Nvidia Container). This i was allowed to stop using. Now this might have seemed fine, but when i started DPP again, there is no nvidia container to kill any more, but the same problem occurs again. 

Thus whatever is reset when i attempt to end task, but not stop a process is there still when the process is not running. I guess one could go crazy over less. At least i have a way to stop this maddening feature if i get the nvidia container up and running again. However it does seem it is not NVidias fault. 

I also noticed that the left side folder tree does appear different when i use the end task function. (Icons appear in a different order, and some that were expanded, clearly will not remain so when the wheel stops bugging me. 

So it has taken a step from plain annoying to mor weird. It does seem to make sense that it is some kind of search / indexing that keeps bugging, but why could it help to restart the Nvidia Container, when it does not help to shut it completely..?

err.. for whatever reason, this is what made DPP more stable for me when working on an internal drive:

right click on desktop >> personalize >> themes >> desktop icon settings >> restore default

I appreciate all the suggestions, but im not using  Geforce experience, and resetting the desktop icon settings did not change anything in my case.