cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP 4.16.11.0 frequently crashes

dpp4user
Contributor

I'm using DPP 4.x for a long time (starting with 3.x long time ago) without stability problems and I'm regularly updating it.

However since I updated to 4.16.11 it frequently crashes while editing an image. It crashes randomly right after a mouse click to some widget. The Windows event log always shows a System.AccessViolationException by Dpp4Main.exe System.AccessViolationException
at Canon.Dpp.Dsf.DPPMWare+NativeMethods.DppMWProcessPreviewImageEx(IntPtr, DppRect, DppPreviewProcessAction, Int32, IntPtr, IntPtr, IntPtr ByRef)
at Canon.Dpp.Dsf.Image.Preview.DSFPreviewProcess.CreatePreviewImage()
at Canon.Dpp.App.Controller.DAPImageController.CreatePreviewImage(Boolean, Boolean)
at Canon.Dpp.App.Controller.DAPImageController+<>c__DisplayClass306_1.<PreviewProcessImageChanged>b__1()
...

which shows a software bug most probably in some of the DPP (native, probably C++ written) modules.

I also observed, less frequently, an access violation (0xc0000005) in Dpp4Batch.exe i.e. DppCoreSubD.dll

(For the software engineers among us: This strongly smells like UB.)

I'm editing compressed CR3 images from an EOS R6.

Does anybody else experience this problem?

How can I report this bug?

I'm going to check how to downgrade to an older DPP version and see whether it works again.

5 REPLIES 5

jrhoffman75
Legend

You can download 4.16.10 or 4.16.0 from the R6 support site.

Does your computer meet the minimum requirements identified for the software?

Does the issue happen with a regular .CR3 file?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I tried 4.16.10.0 and don't observe the crashes so far.
I cannot say whether it is the (downgraded) software version or the re-installation (that might have restored some settings that caused the random crashes).

Thats irony, just after I wrote the recent post, DPP (4.16.10.0) crashed as well (same traceback).

When I had issues with DPP4 (not what you are reporting) doing a Registry clean with free CCleaner resolved my problem. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

wq9nsc
Authority

A long time ago, I ran into a DPP random crash error that was resolved by using Windows to remove the old version and then doing a fresh install.

It has been several years since I have had a crash issue with DPP but I still see it turning into a memory hog and slowing down in long editing sessions; that is resolved by exiting and re-launching DPP. 

It doesn't matter that there is plenty of memory left for the system, it will still become very slow with memory bloat.  I am using a dual CPU HP workstation with 128 GB of RAM per CPU along with dual Nvidia workstation graphics cards with their own dedicated fast video RAM so only a small percentage of total RAM is used by DPP even in its maximum bloat state but once it climbs to 4 or 5 GB it noticeably slows.

My usage probably creates DPP conditions most won't see because this occurs when editing sports events photos where I am using three 1DX series bodies and often capture close to a thousand images between the three.  It might not run into this issue if the images from each body were in a separate directory for editing but because I often use more than one body during the same play I need the images editable in the specific time sequence in which they were captured.

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video
Announcements
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!