Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight5


I recently got a new Windows 8 computer and loaded my Canon A610 software on it.  I was unable to use it until I updated that software by replacing ZoomBrowser with ImageBrowser 1.2.1 (and  Silverlight5), as advised on Canon's Update website.


This allowed me to open and use ImageBrowser and the associated CameraWindow - but only that one time.


Since then I get a failure message at 80% loaded saying there is a problem with Silverlight.  I have reloaded Silverlight only to have the same thing occur - that is I'm able to use ImageBrower just once, and then get the failure message every time after that.


I have also confirmed that Silverlight works as I'm able to open websites I know require it, so it seems that only ImageBrowser thinks it is bad.


I have found the exact same failure being reported on the Microsoft Community Forum, but no solution is given.  Can anyone here help??



Tried this, even took my computer to the computer expert, they could not figure it out, would need "bench time" and that would indicate to leave my computer there. Hope something comes up. Thanks for your help. Gladys

It is October 6th - this is getting old; can't install on Win 8; does Canon care?

Casey76708, Try Windows Live Photo Gallery. It's better, anyway.

Hi pbkessler,


You suggested, "have you tried clearing your Microsoft Internet Explorer program?"


Just tried it. Imagebrowser hung-up at 80%. However, while hung up, it told me a new version was available. So I downloaded & installed that. I then rebooted to ensure IE wasnt in ANY "state" that could impact the program.


Without opening ANY other program, I ran ImageBrowser. Just like every other time after a reboot, it opened. I finished the operation I hadn't finished last time while testing the app (adding all pix), closed it, & restarted the app (WITHOUT starting any other program).


Hung up at 80%.


I'm on 64-bit W8.


Problem not resolved... So I'll continue to use Windows Essentials Photo Gallery to organize my pix. Problem "solved."

Still some suggest trying this or that to make this software work. It seems it has all been tried to no avail. It's the software folks... It's broke and needs to be rebuilt.... Why can't this message seem to get to canon.....????


I have two words for you, not technical.  Good Luck!



Add me to the list of people that are having this issue.  I'm running windows 8 X64 and I've done all the steps that everyone else has tried.  I've scrubbed silverlight 3 times.  I've uninstalled/reinstalled Imagebrowser a number of times.  Is anyone else still having the issue?  Was a fix found?

No help so far... gave up a long time ago & use other s/w.


I have been having a similar problem with W8 and old Zoom browser, so looked for a new version compatible with W8.


then came accross and read all the posts re ImageBrowser on this forum and decided to have another look at my problem:


I could download all pics from my Canon and Sony cameras, no problem, only when trying to access them  in zoombrowser the catalogue would freeze and the scroll bar would dissappear.


I noticed at original opening of zoombrowser it would work untill I expanded the pics folder and the catalogue list was longer than the screen space from top to bottom and I needed to scroll further down..

I also noticed that there was 2 places in the catalogue tree where the folder I was trying to open appeared and zoombrowser expanded BOTH of them and highlighted them both as well??


So I presumed that zoombrowser was trying to open  both folders at the same time.

When I set the computer up we gave the computer a name, "Alma" and  put all pics into the "Libraries" folder;  Pictures\my pictures\ name

Windows then dupilcates this "my pictures" (and all other Libraries folders) in:

Computer\Acer(C)\users\Alma\my pictures \name


I then opened a new folder called "pictures" on the C drive;

Computer\Acer(c)\ pictures  and transfered all my pictures from the "libraries"  folder "my pictures" to this new position leaving  no pics in that  libraries folder.

This meant that there were no pics in the;

Computer\Acer(c)\Users\Alma\my pictures     folder either as Windows had nothing to duplicate

Leaving only ONE copy of the pics in the memory.


ZoomBrowser now works perfectly on W8 with full use of all functions and scrollability


It seems to be a lottery at times, some thought it was windows user profile, some internet explorer, some silverllight (actually many thought this), for me it was none of them, however uninstalling the dropbox client allowed the installation to run to completion and for image browser to work, of course it could stop working again because it's windows (7 x64 for me).  What I can perhaps surmise from these problems, at least in my case is that it was some other program that interrupted comunication with the camera - dropbox rather presumptuously took control of photo uploads without asking (thanks dropbox! - I suggest you drop dropbox ; ) - check autoplay settings and make sure nothing else is in the way, uninstall other image grab programs, make sure silverlight is ok and reinstall 'cleanly' image browser.  good luck and cross your fingers ; )

click here to view the gallery