Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon ImageBrowser EX 1.2.1 fails to load on a Windows8 system due to problems with Silverlight5


I recently got a new Windows 8 computer and loaded my Canon A610 software on it.  I was unable to use it until I updated that software by replacing ZoomBrowser with ImageBrowser 1.2.1 (and  Silverlight5), as advised on Canon's Update website.


This allowed me to open and use ImageBrowser and the associated CameraWindow - but only that one time.


Since then I get a failure message at 80% loaded saying there is a problem with Silverlight.  I have reloaded Silverlight only to have the same thing occur - that is I'm able to use ImageBrower just once, and then get the failure message every time after that.


I have also confirmed that Silverlight works as I'm able to open websites I know require it, so it seems that only ImageBrowser thinks it is bad.


I have found the exact same failure being reported on the Microsoft Community Forum, but no solution is given.  Can anyone here help??




Hello Pbkessler,

What we would normally recommend in this situation would be to uninstall the Canon software and Silverlight to correct for this issue. We are not aware that it is a known issue among these two programs.  After you perform an uninstall, please reinstall the Canon Utilities from the disk and then Silverlight from the web.

If you need immediate contact with us, please contact us via the Service and Support web site.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I'm sorry to say your recommendations did not help. 


Over the past weeks I have repeated uninstalled and reinstalled ImageBrowser, Silverlight and CameraWindow to no avail.  The exercise either did not help at all or just allowed one-time access to ImageBrowser.


I also tried uninstalling the 'old' ZoomBrowser program as well as changing between Internet Explorer 10 and Mozilla Firefox as 'Prefered Browser.  Again, these efforts either did not help or just allowed one-time access to ImageBrowser.


Then, just yesterday, I got lucky!   For some reason Internet Explorer stopped working completely, so I went to Microsoft's Community forum and found one suggestion that I should go to Internet Options/Advanced and then click on Reset Internet Explorer's settings to their default condition.' 


I did this and it fixed Internet Explorer - and then I tried ImageBrowser - and IT FIXED IT AS WELL!!   I've tried it numerous times since then, both yesterday and today - AND IT STARTS SUCCESSFULLY EVERY TIME.


I have no idea why Internet Explorer failed yesterday or what settings I reset in it because I never set or changed settings during the weeks I've had the computer.  I also don't know whether it was responsible for my problems over the past weeks before its failure yesterday - but I'm just pleased I can now use IMageBrowser /CameraWindow!!


A minor problem remain though.  Even though ImageBrowser and CameraWindow work they still do not appear in Windows Auto-Play choices for camera memory cards.  This means that after I plug in my camera memory card I have to manually open ImageBrowser in order to use CameraWindow


Hello again, Pbkessler.

We are glad to hear that you were able to get the Canon software to work properly.  From the question that you asked at the end of your post, it seems like you need to change your AutoPlay settings.  This is not a Canon issue per se, but I have listed the steps in order to assist you. 


- Open AutoPlay by clicking the Start button , clicking Control Panel, clicking Hardware and Sound, and then clicking AutoPlay.


- Under Media, find the type of media that you want to change the AutoPlay setting for.


- Click the action that you want AutoPlay to take when you insert that type of media into your computer.


-Click Save.

We hope you have a great day.  Should you need urgent assistance or want to speak with a live agent, please use our Support and Service web site to contact us directly.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Product Expert Tim from the postings........Do you guys communicate this to your software developer management team? Our do we need to email call Canon in another venue?

Seems like alot of people are having this problem (including me) when you do a google search but no solution yet. If done the uninstall and reinstall and new user accounts and reset IE 9.... Nothing makes Image Browser get past its 80% load up and then freeze.....



Where os this software download on line.... I have windows 7 and have the same issue., I only get 80% of the download...Come on Canon fix it please!
Thank you.

Hi ICUTWO and lernst10!


Thank you for adding to this thread. 


Microsoft has an article in their knowledge-base for cleaning up a corrupted Silverlight installation that tends to resolve the issue.  I have provided a link to it below:


If this is a time sensitive-matter, additional support options are available at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

This Silverlight solution does not cure the Image Browser 80% load failure.  I have now used the Silverlight fix twice to no avail.  After a very long wait the window pops up asking to verify the Silverlight install.


Time to rebuild the software.... I went back to ZoomBrowser and it works fine......

I agree totally with lernst10 – Silverlight is probably not the problem.  See my 22 May entry.  I had reloaded Silverlight (and ImageBrowser) at least 3 times each, all to no avail.  And there were also other submitters, to this forum and the Microsoft forum, who had no success with trying the Silverlight correction suggestions from Canon.


In my case the problem turned out to be Internet Explorer.  I got lucky in that Internet Explorer stopped working and in the process of fixing it (by resetting options) I not only fixed Internet Explorer but then also found that ImageBrowser started working too!


Since then I have been using it successfully at least once or twice a week, but have had one additional incident of hanging at 80% - which I corrected by restarting my computer and then resetting the Internet Explorer options once again.   So I still cross my fingers each time I get to 80% and am also not planning to install the recently released update to ImageBrowser for fear upsetting the applecart! 


But I’d still suggest you try resetting options in Internet Explorer even if you are not having problems with your Internet Explorer. And even if it doesn't’t work for you and if Canon can’t solve your problem, don’t feel bad - because in my opinion ImageBrowser is a lousy program anyway!


It’s got a very user-unfriendly interface and is horrendously slow in the process of finding and displaying stored images.  Each time it opens it initiates searches that I have seen take up to 30 minutes to complete before displaying a full set of images – and then the next time it opens it does the searches all over again!


But I am able to ignore these searches as I only use ImageBrowser to load images from my camera memory cards (because I like its folder-naming scheme).   This works fine in spite of the ongoing searches.  And after the images are loaded I close ImageBrowser and get on with my image processing with other programs.


I was forced to move from ZoomBrowser to ImageBrowser on my Windows 8 computer due to compatibility issues, but would happily revert to ZoomBrowser if it was possible because I still use it on my ‘backup’ Windows XP computer, where it works just fine, running circles around ImageBrowser!


click here to view the gallery