Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Eos R not appearing as drive in Windows 11 via USB


I'm trying to establish a connection to my recently updated to Windows 11 PC, using a usb C to usb A connector from my Canon Eos R. It is failing to get a connection. I've used two separate usb leads with the same result. The camera has no problem appearing as a drive on a Windows 10 computer with the same leads, and its firmware version is up to date.  This is really annoying, as it also makes it impossible to use the Canon utility software.  Does anyone know a ready made solution, or whether there ever will be one?

I also have a Canon XF 300, which I haven't tested yet. It will be a real nightmare if that connection also doesn't work anymore. Well done, Microsoft.. not really.



Actually, the speed of a USB C cable is far faster than directly via the card on a USB-A connection. I didn't wreck the card removing it from the computer, but rather from the camera.  Sorry about that misunderstanding.  The whole process of copying the files, then moving them to the correct folder and renaming them is very tedious.  It is a work around, but the issue here is that Canon have not done anything to resolve this issue for EOS R users.  


Even if you removed the card from the camera prematurely, it is the same issue as if you had the card in a USB drive.  The speed of the USB connection is, as you allude to, dependent on whether the SD card port is part of the computer's internal bus or is accessed by a USB connection externally.  In that case, the speed is dependent on the speed of the USB port, the cable by which the card reader is attached, and the performance of the card reader itself.  My point is that there are many variables, but the likelihood is that the speed of the connection will be faster.
It seems to me that you have two courses of action here.  You can wait until Canon develops a new driver, getting more frustrated as time goes by (and I can see why), or apply the work-around and be able to function.

As a professional photographer, I would go with the latter - you do what you have to do to get the result and move on. I hope that Canon will sort this out, but I have long since used the method I suggested, and it is the most reliable one.

cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

I've been able to use the utility by connecting my EOS r via wifi.  Got a new cable from canon but that still doesn't work BUT got a cheap $8.00 cable from Amazon,  USB c to USB a . No adapter needed and it works!  Wth is going on is beyond me.  It is ridiculous in the extreme.  Not canon, nor HP, nor Microsoft had a useful solution.  I still believe there is a basic incompatibility between canon and windows 11 .  

But we cant seem to get the utility to work nor lightroom to tether becasue the computer doesnt recognize the camera!! 😞  I just bought it and cant return it now .. sure the camera works but not for the things I need it to work for like tethering for my work. 

Hi metalchickphd, I discovered it as the hardware.  I installed Windows 10 on teh same box, and the same result.  Also, I have a laptop with Windows 11 installed and everything works fine with that.  So, I will be, when funds permit, upgrading my motherboard.



First and foremost, make sure you have an internet connection because the PC may need to download a driver.  Allow for a couple minutes for a driver to download.  Try different USB ports.

Is this a new PC?  Many users with home brewed PC platforms using AMD chipsets have experienced issues trying to connect Canon gear on the USB ports.  If you have DIY PC, then, make sure you have the latest firmware in the camera and motherboard.

The Canon apps recommend an Intel chipset.

"The right mouse button is your friend."

Yes, new PC worked fine for a couple months. Then for no apparent reason, it stopped recognizing the EOS R. My old EOS 7D still works as always!  Now, after following a suggestion to uninstall the camera...Windows 11 only sees it as an generic MTP device!  It used to work with Windows 10 but now it's only an MTP device.  What the heck is going on here? I'm regretting the purchase.

Is this an AMD machine?  

You might try deleting and re-installing the EOS Utility software.  If Windows prompts to tell it what to do when it detects a Canon camera plugged into the USB port, then tell Windows to “Take No Action.”

If I may, why are you trying to read the memory card in the cameras as if it were a thumb drive?  You should copy the files off of the memory card with either a card reader or the EOS Utility.  

Trying to access them directly in the camera as if it were a thumb drive is highly inadvisable.  You might corrupt the storage formatting and lose images.

"The right mouse button is your friend."

Waddizzle: I have never had an issue with any OS downloading images using a USB cable until I migrated to Windows 11.  I even have the experience of using my laptop which was previously Windows 10 and has now been upgraded to Windows 11.  It worked fine on Windows 10, and now the camera is not recognised by the laptop with Windows 11.  I built a brand new Windows 11 PC, with the same brand of motherboard as my old Windows 10 machine.  The old Windows 10 machine works perfectly, with the same cable.  This is a Canon issue, because they haven't updated the software to recognise the device under Windows 11.  If it is a Microsoft issue, then Canon should be working with Microsoft to resolve the issue.  It isn't as if this is a recent issue.  People have been complaining about it since last year, when Windows 11 was first release, nearly 12 months now!  Get it sorted!!!!!!!


And before you ask, it is an i5 Intel machine, with a ASUS Intel B85M-G motherboard.