Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Eos R not appearing as drive in Windows 11 via USB


I'm trying to establish a connection to my recently updated to Windows 11 PC, using a usb C to usb A connector from my Canon Eos R. It is failing to get a connection. I've used two separate usb leads with the same result. The camera has no problem appearing as a drive on a Windows 10 computer with the same leads, and its firmware version is up to date.  This is really annoying, as it also makes it impossible to use the Canon utility software.  Does anyone know a ready made solution, or whether there ever will be one?

I also have a Canon XF 300, which I haven't tested yet. It will be a real nightmare if that connection also doesn't work anymore. Well done, Microsoft.. not really.



Product Expert
Product Expert

Hi Droo,

Thanks for checking in with us. If your Windows 10 computer can see the camera then in theory Windows 11 should also be able to see it.

Let's check a few things to see if we can isolate the issue.

First make sure that Wi-Fi is disabled by checking the wireless settings in the camera's menu. If Wi-Fi is enabled then a USB connection won't work.

Beyond that, here are some setup suggestions that might help:
* If it is not there already, make sure the camera is plugged into a USB on the back of your computer. (The front USB ports can be a little weaker sometimes.)
* Since you're having problems downloading, disconnect all other devices except the keyboard, mouse, and camera from the computer.
* Close any other programs you have open, and exit out of any image-related or printer-related programs in the system tray, found in the bottom right corner of your computer screen. If you don't see the program icons, look for a small triangle by the time display. Click that and you should see the icons. You should be able to close them by right clicking the icons and selecting the exit option.

If you still don't get a response from the computer, let's bring up the Device Manager.


Does the camera or an Unknown Device appear, and if so, does it have a "?" or "!" displayed with its description?

If so, right click on the camera icon and select uninstall. When it finishes uninstalling, turn your camera off. Wait a few seconds then turn it on. A window should come up that says FOUND NEW HARDWARE DEVICE, keep clicking the NEXT button, until it finishes. Then see if you can connect to your camera once again.

If you see another camera, like a webcam, listed in the Device Manager, right click on it and select DISABLE. It is possible that you are getting interference from that device. When you are done with your tests, you can reactivate it by right clicking on it and selecting ENABLE.

No luck with any of these suggested tweaks. The only place where the camera shows up is in portable devices.. as an MTP USB device.. and as an eos digital device icon in printers and devices. It's barely there. And the troubleshooter can't help. 

I think it's pretty obvious there is no Windows 11 driver for the Eos R yet. By comparison, I can see my old 6D as a separate drive, and open it like the others.  I can get around all of this by putting the SD card in my computer's card reader. But I'm worried my canon xf300 will have the same issues, and I don't have a flash drive reader. But I do have an old Mac Pro running Catalina. So I'll see if Canon's XF utility software still reads the camcorder on that system. It should..




Nick2000 has covered many of the likely scenarios for an unrecognized USB device.  If the Camera appears correctly in Device Manager, also look at Disk Management to see if windows has assigned a drive letter.  If not, it will not display in Windows Explorer.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks to all for the helpful suggestions. I gave up trying to get my new Windows 11 desktop to read the Eos R. But the latest Canon XF utility software reads my XF300 just fine, so I can download all my files without having to purchase a compatible flash drive adaptor. That's something of a relief, as the XF300 is now quite old, though still very useful.



Honestly, we see this kind of thing quite often and the answer that seems to work best is actually the simplest.

Plugging the whole camera into your computer, means the card has an extra step to communicate with the camera, and the camera with the computer.  Instead, simply turn off your camera, remove the card and plug it into a suitable card slot in the computer or get a USB card reader (lots available).  The computer will recognize the card as a drive and you can then download your images.

Apart from the lack of complication, there are two other benefits.  It's faster, as the connection will be using faster technology, and it doesn't drain your camera battery.

It's amazing how the simplest solution is usually the most elegant.

cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

Not being able to use EOS utility means assigning file names manually and inability to control camera from pc. Using a card reader is a stop gap solution at best. 

Hi Tronhard, I've been using my USB cable since forever, and I've never had an issue until I moved to Windows 11.  The issue here is strictly to do with Windows 11 and there is no hardware issue.  That indicates to me that Canon have not produced a driver suitable for Windows 11, even though Windows 11 has been well signalled.  Additionally, if you want to fry a memory card, handle it all the time.  You will eventually succeed.  The only time I ever remove a memory card from my camera (I now have 128MB card, so that very rarely happens) is when it gets full when I'm shooting.  I haven't managed to succeed in that since I've had my EOS R, so there is no need.  Handling cards almost guarantees that the card will fault.  In all my time using digital cameras, over a decade, I've only ever had one fault, and that was on my first EOS camera, a 300D, when I tried to change the card while it was still writing.  So, your suggestion is the worst possible suggestion.  The best suggestion is that Canon gets its act together and fixes the issue, so that people don't have to remove the card from the camera.  I will tell you this: I have done a test, by using the same cable that I previously used on my old computer, with the same brand motherboard, and also on my laptop before it was upgraded to Windows 11.  When it was installed with Windows 10, there was no issue.  


And I also don't agree with you about how fast it is to download images using a card reader.  One, I have to take the card from camera, locate the card reader (I always have the USB cable attached to my computer for downloads, so I never have to locate that) and then I have to download all of the images, and then rename the folder to the date (done automatically by the software, according to camera and date) and then move the files from the various dates into the correct folder, a very time consuming an tedious task.  I would also note that all of the later cameras, EOS R5 and forward, have a Windows 11 compatible firmware update.  The EOS R does not, and yet it is still a currently for sale camera.  Pretty slack, if you ask me. 😉


Gavin, I sincerely and politely tried to help the OP (DROO) with their issue, but you have subsequently responded to this when you should have started your own thread to deal with your specific issues.  Furthermore, your responses are full of angst that is not helping anyone.

To quote you: "Handling cards almost guarantees that the card will fault.  In all my time using digital cameras, over a decade, I've only ever had one fault, and that was on my first EOS camera, a 300D, when I tried to change the card while it was still writing."

I have used cards in the way I have suggested for almost 20 years without any issue. The fact that you actually admit the one issue you had was your own action in pulling a card out while it was writing, is your issue as a user and there is no validity to extrapolate that to an essential inherent issue with cards themselves. 

I worked on the design for Windows interface, and the intent was always that you should use the Eject feature (either in File Manager, or from the tool in the Windows tray) to ensure that the card does not have open file connections to the computer.  Pulling the card prematurely creates a risk that the card will corrupt its FAT system and render it unusable.  That is not an issue with Windows, or with cards per se, it is user error.

I am not decrying the need for Canon to resolve the driver issue, but I offered the OP a work-around based on the information they initially gave,

The initial post did not include the information that the OP wanted to rename files en masse - that is your contribution. 

To deal with your objections:

Depending upon the speed of your USB drive connection, I would normally expect that copying from the SD card would be faster than a USB drive cable - it should certainly not be slower. 

As to being able to batch rename files: you can do that using DPP from the card once it is connected via the reader and recognized as a drive on your PC, or after the files are copied from the card to the hard disc.  If you do the latter, it will process them at the speed of the hard drive. So, it's just a matter of working slightly differently from the way you did before.  The point is you can achieve your ends if you are prepared to be flexible.

cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris