cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera connect app - can't finalize the connection

aurelija
Apprentice

Hi! I own canon eos 5d iv, and been using camera connect app before with no problems. However after it was updated recently, I can't finalize the connection with my camera. I arrive to the step where I need to register new camera and choose the connection (just like in the pic), I can see my camera on the phone, but there are any options to finalize this step. When I close the window, it asks to register new camera again. I tried to uninstall and reinstall the app, reboot and restart my phone, delete all camera settings- nothing changes

Screenshot_20230325_083432_Camera Connect.jpg

Screenshot_20230325_083541_Camera Connect.jpg

4 REPLIES 4

Nick2020
Product Expert
Product Expert

Hi aurelija,

Thanks for checking in.

A recent update to iOS added Wi-Fi Assist that has been affecting the connection between our cameras and CameraConnect. That auto switches to whatever network is available, but that can prevent the camera connection from getting established.

If you're on an iPhone, here are the steps to shut off Wi-Fi Assist:

1. Open Settings
2. Select Cellular
3. Scroll past the list of all installed apps
4. The next setting is Wi-Fi Assist

You may want to reset the camera wireless settings to default as well, for a fresh start. To reset the camera wireless settings to default, just follow the instructions below.
1. Turn the camera on and press the “Menu” button. Navigate to the third tools tab which is labeled in yellow and has a symbol of a wrench.
2. Highlight and select “Wi-Fi function” on this menu screen by pressing SET on the camera.
3. Press the “DISP” button on the camera.
4. Select “Clear Wi-Fi settings” and then select “OK” when it’s displayed on the camera’s screen.

If problems persist, please elaborate on what phone you're using and what operating system it is running.

aurelija
Apprentice

Hi, thanks for reply. 

the problem is that in Camera connect app I can't move forward from the "Wi-fi connection" window, when it shows that I am connected to my camera (its name is displayed there). I switched off automatic switch to mobile internet in my android. But no changes. 
Any ideas how I can make it work?

Hello aurelija,

I agree with shadowsports. Let's reset the wireless settings on the camera to factory defaults and use the camera generated name for the network (camera access point). Delete the previously shown "network name" for the camera from your phone's WIFI selection menu and then retry.

shadowsports
Legend
Legend

Greetings,

Reset the Network Setting on your camera.  Do not use a nickname for the camera.

Delete any saved "nickname profiles" in Canon Connect for the device.  

Retest 

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It
Avatar
click here to view the press release
Announcements