Showing results for 
Show  only  | Search instead for 
Did you mean: 

Camera Connect App not working

A month ago I got a new Apple 8 with IOS 12 on it.
I got it Connected to my EOS 70D and had it working.
It was not always connecting easily but it would connect.
Today while trying to download pictures on a holiday it won’t connect.
At first it Connected but only showed about 6 pictures.
When I selected a picture to view and download. After waiting a minute or 2. The picture was still blurry and could not download.
I tried reboot on phone and camera. This time it just showed black squares where the picture should be.
I have now deleted and tried everything but cannot get the App to connect to the camera.
When I go through the App setup I can assign the SSID and the camera shows the connection but stays on that page and never completed the configuration with the phone.
There was a recent update on my iPhone and there is a selection which leads me to believe there was an update to the app.

Thank William!
I know when I was having a problem I did delete the App and reboot the phone.
I thought I had deleted the WiFi settings on the camera as well.
I did delete the App and reboot the phone.
Then I deleted the WiFi settings on the camera and rebooted it.
Installed the App and setup the WiFi connection on the camera.
It Connected as soon as I started the app and all is good!
Thanks again.

View solution in original post



Having a similar issue since upgrading to a Glaxy Note 9 from a Note 4 - both Android. Camera connect worked great on the old phone and my EOS 80D. Once the camera and phone were connect via WiFi, a click on "Remote Live View Shooting" in the APP established the EOS 80D connection in the APP and I was in business. With the new camera, WiFi connects just fine. But the click on "Remote Live View Shooting" launches "Easy Connection Guide" which never attaches to the WiFi connection. The screen sequence ends with something like "CLICK TO SEE WIFI CONNECTIONS", which of course shows the SSID of the camera and a status of connected. And that's all she wrote. The APP just sits there as useless as a wart. I have to kill "Easy Connection Guide" as it never terminates and has no DONE button.


Is this something broken in Camera Connect Or an incompatability with the latest Android? The Note 4 had not had a system update distributed in three years, so both the APP and OS were back leveled.

PROBLEM SOLVED. Apparently the latest version of Camera Connect is picky about the camera nickname. We had it set to the name of the camera owner. Once we reset it to the default "EOS80D" the APP connected to the phone immediately upon the WiFi connection being established. Apparently the APP didn't recognize the camera's SSID built from the non-default nickname.

Ok, I have tried everything that was mentioned above and I still have the issue of blurry images and images that don't want to download.

Worked perfectly before until I updated my Iphone 8 to ios 12.4.1

Canon 80D


Any other help would be greatly appreciated.



Switched from Android S2 to Android Se5 tablet, camera connect worked fine for a time, now stuck on quick connect loop, needs password (I don't have one). Have deleted and rebooted then reinstalled app, no luck. EOS80D. Help please- on a big vacation and very frustrating. (App does show it is seeing camera on quick connect page, but then says not connected).

Just started having the same issue on vacation. I have uninstalled the app and reinstalled and when I get to the device can operate the camera, it immediately disconnects. What’s going on?

I just started having this problem as well, was working fine yesterday afternoon but suddenly in the evening and now it refuses to actually connect. WiFi connection is made but never gets to the actual camera linking to the app. Did all the things suggested - deleted app, shut down phone, restarted and reinstalled app, turned off WiFi on camera, restarted and turned WiFi back on, still no connection. Sees the WiFi connection just fine, but no camera connection. No iOS updates.


Camera: Canon PowerShot SX620 HS WiFi
Phone: iPhone 6, iOS 12.4.1

@koshka42 wrote:

Camera: Canon PowerShot SX620 HS WiFi
Phone: iPhone 6, iOS 12.4.1

I have an iPhone 6s, and mine updated the iOS about a week ago to 12.4.1.  Today it wants to install iOS 13.

"The right mouse button is your friend."

Oh, I didn’t see an OS update when I looked, I wonder if that will help? Thanks for the heads up!

Updating didn't weem to do anything for me.