Showing results for 
Show  only  | Search instead for 
Did you mean: 

GX10 & G40: Cannot connect to an wifi access point



on my G40 I was always wondering why the camera wasn't connecting to my wifi network. Ever thought it was a bugged firmware or so. 

Today I got my GX10 and the problem is exactly the same. conencting directly to the camera works... but if I want to connect the camera to various wifi networks (tried many kinds of names and security settings) nothings gonna happen. It seems it's not even try to connect (connection profile is set properly).

Is there a magic button that I have to push to finally connect the camera? Or is canon maintaining this bug since the G40?


Thanks, Denny


From the the GX10 Manual:


GX10 Network Functions.PNG


Yes, I agree that is rather limiting, but it's good that you appear to have found a workaround. I just thought others might be interested in how you did it. 

View solution in original post


Rising Star

I have no problem connecting my HF-G40 to my home Wi-Fi network (WAN). Just followed the procedure in the User Manual. Hardly ever use it though as activating Wi Fi on the camcorder drains the battery in no time.

did you use WPS for setup or do you scanned for APs?... that's the only thing a can't try because my access points are not supporting WPS. If I selected on of the APs the camera has found I'll get asked for passphrase and so... but at the end it wont even try to connect to the network... It'll only save the settings and that's it...

I used the scan for AP’s option.

Product Expert
Product Expert

Hi dennydeutscher,


Thanks for checking in with us.


The Wi-Fi settings can vary quite a bit depending on what you're trying to accomplish and how you're setting it up.


In case you don't have the manual at hand, you can reference it on the link below, and the Wi-Fi section begins on page 104:


If you're trying to connect to a tablet or smartphone, then you could use Browser remote for that. An overview on Browser Remote starts on page 111 of the manual.


In this video tutorial we go through the basics of setting up a connection with Browser Remote. It is for a different camera, but the general principles are the same, and that starts about 1:35 min into the video:


thanks for the videos... I already knew them.

I want to remot control the camera while it's connected to our wifi network. I will do a video later, to proof you that I'm not a idiot.

As promised... the video 

I've created a wifi network for just this video with the passpharase "12345678" just to avoid someting is going wrong with charset issues.

As you can see it won't connect. I have this issue on all 3 cameras with wifi built in: G40 and 2 x GX10.

or is there a magic "connect" button I've missed?

thanks in advanced

The Wi-fi configuration menu's on the GX10 are a bit different (more convoluted) than on my HF-G40, but watching your video and consulting the GX10 online User Manual, one thing occurs to me is that at 0:15 seconds into the video, where you are at the 'Select the network connection method' screen, you select 'Infrastructure', whereas the manual (p112) states that to use the Remote Browser function, you should select 'Camera Access Point' as the connection method.

Yah sure... But i want it to work in infrastructure... because the remote control is glueless as soon as the camera turned off the Wifi is gone... and the control device (pc, tablet) connecting to another wifi. Reconnecting after swapping batteries is a pain in the ass this way. Despite that I wonder why the infrastructure mode is included at all when it's not connecting to any AP?

Rising Star

Just tested it again since I changed Internet Provider and it works fine. Like I said, I hardly ever use it. Really my only interest was using the Media Server to stream over WAN to my smart TV. It worked but the playback was sluggish. Easier to just connect directly to the TV with the HDMI cable.

click here to view the gallery